Bug 806606 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c28c4115360cf3f41c7d784182a...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 06:25 EDT by Elad Alfassa
Modified: 2012-07-10 23:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 23:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad Alfassa 2012-03-25 06:25:16 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.x86_64
reason:         SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
time:           Sun 25 Mar 2012 12:25:02 PM IST

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'create' accesses on the file videostats.sxx.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed create access on the videostats.sxx file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                videostats.sxx [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-11.0-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-104.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.x86_64 #1 SMP Mon Mar
:                              19 03:03:39 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Sun 25 Mar 2012 12:24:11 PM IST
:Last Seen                     Sun 25 Mar 2012 12:24:17 PM IST
:Local ID                      33bd7993-210c-452b-bf3f-8934c4ecddfe
:
:Raw Audit Messages
:type=AVC msg=audit(1332671057.902:67): avc:  denied  { create } for  pid=1705 comm="plugin-containe" name="videostats.sxx" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1332671057.902:67): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4a9b588e58 a1=442 a2=1b6 a3=ffffff00 items=0 ppid=1663 pid=1705 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,user_home_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-26 10:10:28 EDT
Where is "videostats.sxx" created? It looks like you will need to do the restorecon command on your homedir

$ restorecon -R -v ~/

should fix. Also please update to the latest policy. We added some fixes.

$ yum update selinux-policy-targeted --enablerepo=updates-testing

If the problem still persists, pleese reopen the bug. Thank you.
Comment 2 Julian Sikorski 2012-06-28 15:00:53 EDT
I got directed here by setroubleshoot when trying to report a problem with googletalk-plugin. Issue would happen whenever I try to start a video call from gmail web client.
selinux-policy-3.10.0-132.fc17.noarch
google-talkplugin-3.1.4.0-1.x86_64
Comment 3 Daniel Walsh 2012-06-29 17:27:22 EDT
Did you try the restorecon?
Comment 4 Elad Alfassa 2012-07-02 03:30:02 EDT
restorecon did fix this issue for me.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.