Bug 806614 - Upgrade request for Django from 1.3.1 to 1.4
Upgrade request for Django from 1.3.1 to 1.4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Django (Show other bugs)
17
All All
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On: 806463
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 07:53 EDT by Jos Vos
Modified: 2012-05-02 00:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: Django-1.4-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2012-03-25 07:53:45 EDT
Please upgrade Django to version 1.4, that has now been officially released.  See https://www.djangoproject.com/weblog/2012/mar/23/14/ for the announcement and https://docs.djangoproject.com/en/dev/releases/1.4/ for the release notes.
Comment 1 Matthias Runge 2012-03-26 03:08:33 EDT
Thank you for the heads-up. There's already a tracking bug regarding django-1.4
https://bugzilla.redhat.com/show_bug.cgi?id=806463

Please note, there's also a build for f18
Comment 2 Fedora Update System 2012-03-28 17:24:27 EDT
Django-1.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/Django-1.4-1.fc17
Comment 3 Fedora Update System 2012-03-29 23:02:17 EDT
Package Django-1.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Django-1.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4897/Django-1.4-1.fc17
then log in and leave karma (feedback).
Comment 4 Jos Vos 2012-03-31 16:20:45 EDT
FWIW: this package does not build on RHEL 6.2 (i.e. CentOS 6.2). A clean mock build fails there with:

+ /usr/lib/rpm/find-lang.sh /builddir/build/BUILDROOT/Django-1.4-1.el6.x86_64 django
No translations found for django in /builddir/build/BUILDROOT/Django-1.4-1.el6.x86_64

I didn't further look at the reason for this yet (will do so within a few days, I need Django 1.4 on RHEL6 anyway), but maybe the package can be improved to build on both F17+ and RHEL6.2+.
Comment 5 Matthias Runge 2012-04-01 15:24:00 EDT
@Jos, which SRPM did you try?
Django from f17?, python-django from f18? both build ok in fedora build environment.

Since django 1.2 (from epel6) and django-1.4 are incompatible in some way, we can't just upgrade djangos epel6 version from 1.2 to 1.4 (although I absolutely understand your wish to do so). E.g ReviewBoard is not compatible with django-1.4
cf. http://www.reviewboard.org/docs/releasenotes/dev/reviewboard/1.6.5/
Comment 6 Jos Vos 2012-04-01 15:38:31 EDT
I tried Django-1.4-1.fc17.src.rpm (downloaded from koji) and I just tried python-django-1.4-3.fc18.src.rpm, which fails at the same point.
Comment 7 Matthias Runge 2012-04-01 16:26:03 EDT
Thanks for the info. I can confirm, they're failing, at least in a consistent way. This brings up the question, what is the difference between epel6 version of %find_lang and fedora 17(+)? 
Django puts its languages under /usr/lib/python and not under /usr/share...

Jos, would you take a look onto the following build? I think, I got it.

http://koji.fedoraproject.org/koji/taskinfo?taskID=3955054 (It is still building, but currently in checks-section)?
Comment 8 Jos Vos 2012-04-01 17:00:51 EDT
Yep, that works.  In the meantime I found out that the find_lang in RHEL6 (rpm 4.8.x) looks for paths .../share/locale/..., while newer find_lang script from rpm 4.9.x looks for the more generic paths .../locale/..., so this was indeed the problem.
Comment 9 Fedora Update System 2012-05-02 00:46:39 EDT
Django-1.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.