Bug 806653 - Cannot update up to gcc 4.6.3
Cannot update up to gcc 4.6.3
Status: CLOSED DUPLICATE of bug 802080
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
16
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 14:31 EDT by Alexander Pupeikis
Modified: 2012-03-26 04:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 04:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Pupeikis 2012-03-25 14:31:15 EDT
Description of problem:

Impossible to update up to gcc 4.6.3 and appropriate C++ libraries. I have Clang 2.9-6 and LLVM installed on my machine. Due to Clang's dependency on gcc 4.6.2 it's illegal to make an update.
Message: clang-2.9-6.fc16.i686 requires gcc-c++ = 4.6.2 : Success - empty transaction 

Version-Release number of selected component (if applicable):
cpp-4.6.3-2
gcc-4.6.3-2
gcc-c++-4.6.3-2
libgomp-4.6.3-2
libstdc++-4.6.3-2
libstdc++-devel-4.6.3-2
libtool-2.4-9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Please, update up to LLVM 3.0
Comment 1 Adrian Tudor Panescu 2012-03-25 16:53:04 EDT
Same issue:

Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package cpp.i686 0:4.6.2-1.fc16 will be updated
---> Package cpp.i686 0:4.6.3-2.fc16 will be an update
---> Package gcc.i686 0:4.6.2-1.fc16 will be updated
---> Package gcc.i686 0:4.6.3-2.fc16 will be an update
---> Package gcc-c++.i686 0:4.6.2-1.fc16 will be updated
--> Processing Dependency: gcc-c++ = 4.6.2 for package: clang-2.9-6.fc16.i686
---> Package gcc-c++.i686 0:4.6.3-2.fc16 will be an update
---> Package gcc-gfortran.i686 0:4.6.2-1.fc16 will be updated
---> Package gcc-gfortran.i686 0:4.6.3-2.fc16 will be an update
---> Package libgfortran.i686 0:4.6.2-1.fc16 will be updated
---> Package libgfortran.i686 0:4.6.3-2.fc16 will be an update
---> Package libgomp.i686 0:4.6.2-1.fc16 will be updated
---> Package libgomp.i686 0:4.6.3-2.fc16 will be an update
---> Package libquadmath.i686 0:4.6.2-1.fc16 will be updated
---> Package libquadmath.i686 0:4.6.3-2.fc16 will be an update
---> Package libquadmath-devel.i686 0:4.6.2-1.fc16 will be updated
---> Package libquadmath-devel.i686 0:4.6.3-2.fc16 will be an update
---> Package libstdc++.i686 0:4.6.2-1.fc16 will be updated
---> Package libstdc++.i686 0:4.6.3-2.fc16 will be an update
---> Package libstdc++-devel.i686 0:4.6.2-1.fc16 will be updated
---> Package libstdc++-devel.i686 0:4.6.3-2.fc16 will be an update
---> Package libtool.i686 0:2.4-8.fc16 will be updated
---> Package libtool.i686 0:2.4-9.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: clang-2.9-6.fc16.i686 (@updates)
           Requires: gcc-c++ = 4.6.2
           Removing: gcc-c++-4.6.2-1.fc16.i686 (@fedora)
               gcc-c++ = 4.6.2-1.fc16
           Updated By: gcc-c++-4.6.3-2.fc16.i686 (updates)
               gcc-c++ = 4.6.3-2.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 2 Jakub Jelinek 2012-03-26 04:33:31 EDT
There is a separate update:
https://admin.fedoraproject.org/updates/FEDORA-2012-4574/llvm-2.9-9.fc16
Feel free to give it karma.
Comment 3 Michel Alexandre Salim 2012-03-26 04:44:19 EDT

*** This bug has been marked as a duplicate of bug 802080 ***

Note You need to log in before you can comment on or make changes to this bug.