Bug 806708 - NFSISO installation doesn't work
NFSISO installation doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-25 23:47 EDT by Charles R. Anderson
Modified: 2012-04-05 03:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-17.16-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 03:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2012-03-25 23:47:42 EDT
Description of problem:

NFSISO installation from this test case doesn't work:

https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_default

Version-Release number of selected component (if applicable):
Fedora 17 Beta RC1

How reproducible:
always

Steps to Reproduce:
1. Use livecd-iso-to-disk to write netboot.iso to USB
2. Boot USB into graphical installer
3. Modify Fedora 17 repo to use NFS
4. Point to NFS server path containing only the DVD.iso file

Actual results:
Anaconda doesn't recognize the .iso and loopback mount it to find the repository.

Expected results:
Anaconda should loopback mount the .iso from the NFS mount and use that as the repo.

Additional info:
Comment 1 Charles R. Anderson 2012-03-26 10:16:47 EDT
Using inst.repo=nfsiso: or repo=nfsiso: doesn't work either.  The X server never comes up--the system hangs right after this message:

rpcbind: rpcbind terminating on signal. Restart with "rpcbind -w"

and the text screen resolution changes (kernel modeset).
Comment 2 Chris Lumens 2012-03-26 10:38:25 EDT
Please attach /tmp/anaconda.log, /tmp/program.log, and /tmp/syslog to this bug report.  Thanks.
Comment 3 Adam Williamson 2012-03-26 11:14:10 EDT
If this is correct as described it'd constitute a beta blocker (we took a similar bug as blocker during TC stage).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2012-03-26 13:44:29 EDT
Discussed at 2012-03-26 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion "The installer must be able to use the HTTP, FTP and NFS remote package source options".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2012-03-26 17:14:01 EDT
I found the same as Charles, more or less - it'd hang at the messy dracut message screen right before X should come up with the language selection screen. It never got to a point where you could get at the logs.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-03-26 17:29:52 EDT
actually, just tried it a couple more times and it worked, I think I screwed up the command line the first time. So I can't reproduce this; it works for me with repo=nfs:server:/path or repo=nfsiso:server:/path .

I used an NFSv4 server running on F16, and tested from a VM booting from the netinst.iso . The NFS server directory contains only the F17 Beta RC1 DVD iso, no other file.
Comment 7 Brian Lane 2012-03-26 19:57:34 EDT
The original description isn't expected to work, setting up NFS from the package dialog should point to a repo, not an iso or directory with an iso.

I can reproduce problems with repo=nfs: failing after NetworkManager is started from the root fs so this should be fixed by fixing the network handoff from dracut to NetworkManager.
Comment 8 Kamil Páral 2012-03-27 04:07:52 EDT
> I can reproduce problems with repo=nfs: failing after NetworkManager is started
> from the root fs so this should be fixed by fixing the network handoff from
> dracut to NetworkManager.

Same problem here. When I use "repo=nfsiso:" option the boot freezes after "Starting Network Manager".
Comment 9 Will Woods 2012-03-27 11:11:22 EDT
There was a bug introduced into the dracut->NM handover code which should be fixed by this commit:
  http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=1a3dda9

For root=live:nfs:... there was a similar problem which should be fixed by these two patches:
  http://thread.gmane.org/gmane.linux.kernel.initramfs/2569
Comment 10 Kamil Páral 2012-03-27 11:16:58 EDT
Although these are technically two different bugs, they are so close that I propose to track both of them here and close this bug once anaconda containing both fixes hits stable.
Comment 11 Fedora Update System 2012-03-27 20:10:02 EDT
anaconda-17.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.15-1.fc17
Comment 12 Fedora Update System 2012-03-28 01:52:48 EDT
Package anaconda-17.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4745/anaconda-17.15-1.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-03-28 19:22:56 EDT
anaconda-17.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.16-1.fc17
Comment 14 Fedora Update System 2012-03-29 00:13:27 EDT
anaconda-17.16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Kamil Páral 2012-03-29 07:48:18 EDT
Verified fixed with F17 Beta RC2.
Comment 16 Kamil Páral 2012-04-05 03:37:29 EDT
This has regressed in F17 Beta RC3. Dracut now doesn't know nfsiso mount type.

[   10.876167] dracut: anaconda mounting NFS repo at nfsiso
mount: unknown filesystem type 'nfsiso'
[   10.897754] dracut Warning: Couldn't mount nfsiso
dracut Warning: Couldn't mount nfsiso
[   10.922911] dracut Warning: no suitable images
dracut Warning: no suitable images

You can only see that when booting from direct kernel boot, either in VM or from PXE.

The only boot option I used was:

repo=nfsiso:192.168.1.1:/mnt/data/iso/Fedora-17-Beta-i386-DVD.iso
Comment 17 Kamil Páral 2012-04-05 03:43:34 EDT
This is a different bug, bug 810005. Closing again.

Note You need to log in before you can comment on or make changes to this bug.