Bug 806758 - [abrt] deluge-gtk-1.3.3-1.fc16: __init__.py:52:_init:RuntimeError: could not open display
[abrt] deluge-gtk-1.3.3-1.fc16: __init__.py:52:_init:RuntimeError: could not ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:44dad3ed2a40d9c18cbe586456d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 03:33 EDT by Luca Pellacani
Modified: 2012-03-27 08:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 08:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Pellacani 2012-03-26 03:33:43 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/deluge-gtk %U
comment:        Deluge put in cron-tab and started automaticaly from "at"
executable:     /usr/bin/deluge-gtk
kernel:         3.2.9-2.fc16.x86_64
reason:         __init__.py:52:_init:RuntimeError: could not open display
time:           ven 23 mar 2012 16:00:01 CET
uid:            2007
username:       pella

backtrace:
:__init__.py:52:_init:RuntimeError: could not open display
:
:Traceback (most recent call last):
:  File "/usr/bin/deluge-gtk", line 9, in <module>
:    load_entry_point('deluge==1.3.3', 'gui_scripts', 'deluge-gtk')()
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
:    return get_distribution(dist).load_entry_point(group, name)
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2279, in load_entry_point
:    return ep.load()
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 1989, in load
:    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/__init__.py", line 1, in <module>
:    from gtkui import start
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 42, in <module>
:    reactor = gtk2reactor.install()
:  File "/usr/lib64/python2.7/site-packages/twisted/internet/gtk2reactor.py", line 377, in install
:    reactor = Gtk2Reactor(useGtk)
:  File "/usr/lib64/python2.7/site-packages/twisted/internet/gtk2reactor.py", line 103, in __init__
:    import gtk
:  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
:    _init()
:  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
:    _gtk.init_check()
:RuntimeError: could not open display
:
:Local variables in innermost frame:
:sys: <module 'sys' (built-in)>
:sys_path: ['/usr/bin', '/usr/lib64/python27.zip', '/usr/lib64/python2.7', '/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', '/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', '/usr/lib64/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/FontTools', '/usr/lib64/python2.7/site-packages/gst-0.10', '/usr/lib64/python2.7/site-packages/gtk-2.0', '/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode', '/usr/lib/python2.7/site-packages', '/usr/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info']
Comment 1 Calum 2012-03-27 08:11:03 EDT
That error is because you are trying to run an X application (deluge-gtk) in cron-tab without a display. You should be using deluged instead as it's designed to run in the background plus rather than using crontab you can use init/systemd.

Note You need to log in before you can comment on or make changes to this bug.