Bug 806795 - NFS: Log - change from warning to error
NFS: Log - change from warning to error
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 05:21 EDT by Sachidananda Urs
Modified: 2014-03-30 21:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 08:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-03-26 05:21:10 EDT
When the operations fail and file/directory is not created, the log should be `ERROR' not `WARNING':


[2012-03-25 23:09:29.494395] W [client3_1-fops.c:514:client3_1_unlink_cbk] 0-nfs-test-3-client-0: remote operation failed: Read-only file system
[2012-03-25 23:09:29.494414] W [nfs3.c:3358:nfs3svc_remove_cbk] 0-nfs: 14633cb0: /one/linux-3.2.11/arch/x86/xen/xen-ops.h => -1 (Read-only file system)
[2012-03-25 23:09:29.495138] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-0: remote operation failed: Read-only file system
[2012-03-25 23:09:29.495555] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-1: remote operation failed: Read-only file system
[2012-03-25 23:09:29.496054] W [client3_1-fops.c:514:client3_1_unlink_cbk] 0-nfs-test-3-client-1: remote operation failed: Read-only file system
[2012-03-25 23:09:29.496081] W [nfs3.c:3358:nfs3svc_remove_cbk] 0-nfs: 19633cb0: /linux-3.2.11/arch/x86/include/asm/mmu_context.h => -1 (Read-only file system)
[2012-03-25 23:09:29.496211] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-0: remote operation failed: Read-only file system
[2012-03-25 23:09:29.496333] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-1: remote operation failed: Read-only file system
[2012-03-25 23:09:29.496799] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-0: remote operation failed: Read-only file system
[2012-03-25 23:09:29.497386] W [client3_1-fops.c:1590:client3_1_setattr_cbk] 0-nfs-test-3-client-1: remote operation failed: Read-only file system
Comment 1 Vijay Bellur 2012-04-27 08:31:14 EDT
This should be handled more appropriately by a translator at a higher level. For instance with replicate, the right behavior is to log these messages at log level WARNING in the client protocol. Only replicate will be in a position to determine whether the operation is a failure or not. Since replicate provides resiliency against these kind of errors, it is better not to confuse the user with ERRORS.

Note You need to log in before you can comment on or make changes to this bug.