Bug 80685 - up2date lilo test failure
up2date lilo test failure
Status: CLOSED DUPLICATE of bug 61512
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-29 15:26 EST by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-29 15:26:55 EST
Description of problem:
The up2date agent has an issue with updating the kernel.  What happens is, once 
you have updated several kernels, the lilo label names become too long for 
lilo.  It appears the naming schema for old kernels is linux-up.bak1 , linux-
up.bak12, linux-up.bak123, linux-up.bak1234.  The last in that list is where 
lilo complains about the character length of the string, 16.  So after an 
up2date that updates the kernel you have, up2date gives an error saying lilo 
test failed.

Version-Release number of selected component (if applicable):
RedHat 7.3 on i686
LILO version 21.4-4
2.4.18-19.7.xsmp
Red Hat Update Agent v2.8.39


How reproducible:
100%

Steps to Reproduce:
Simply supply an image within lilo.conf which exceeds the 16 character label 
name limit.

1. Give an image a label name >= 16 characters
   Label for an Image: LABEL_0123456789
2. run lilo
   you get) Lilo Error: Fatal: Label "LABEL_0123456789" is too long

I am aware this is more a lilo thing but if you want up2date to be completelty 
transparent/hands off, the up2date binary should know about this label name 
limit and adjust what names it gives to the old kernel images.

Actual results:


Expected results:


Additional info:
The fix is easy: just rename the labels, run lilo again and reboot.
Comment 1 Adrian Likins 2003-01-15 00:33:36 EST
I tend to think of this as a dup of #61512 (up2date verify sanity
of boot loader configs before attempting to modify them)

Since up2date currently assumes that the existing bootloader
configs are working. 

Also, some versions of up2date did a crappy job of appending
to the name. This should be fixed in current versions of up2date
(for 8.0, possible errata for 7.x).

This bug seems to be a combo of the above.



*** This bug has been marked as a duplicate of 61512 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:50:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.