Bug 806872 - fedora-easy-karma crashes from behind a mandatory non-transparent proxy
Summary: fedora-easy-karma crashes from behind a mandatory non-transparent proxy
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fedora
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-26 12:13 UTC by James Wilkinson
Modified: 2012-03-28 16:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-28 16:38:33 UTC
Type: ---


Attachments (Terms of Use)

Description James Wilkinson 2012-03-26 12:13:06 UTC
Description of problem:
Hi. I'm on an IPv4-only network with a mandatory non-transparent proxy (i.e. the only way to access the WWW is by configuring clients to use a proxy). When I try to run fedora-easy-karma, it gives me a traceback almost immediately.

Exporting HTTP_PROXY or http_proxy doesn't seem to help.

Version-Release number of selected component (if applicable):
fedora-easy-karma-0-0.15.20110825git36efb338.fc15.noarch
python-fedora-0.3.26-1.fc15.noarch

How reproducible:
Steps to Reproduce:
1. Firewall off direct access to the Internet, but ensure you have access to an HTTP proxy.
2. http_proxy=http://proxy:80/ fedora-easy-karma
  
Actual results:
Getting list of installed packages...
Getting list of packages in updates-testing...
Traceback (most recent call last):
  File "/usr/bin/fedora-easy-karma", line 510, in <module>
    FedoraEasyKarma()
  File "/usr/bin/fedora-easy-karma", line 310, in __init__
    testing_updates = bc.query(release=release, status="testing", limit=1000)["updates"]
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 147, in query
    return self.send_request('list', req_params=params, auth=auth)
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 344, in send_request
    auth_params=auth_params, retries=retries)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 387, in send_request
    request.perform()
pycurl.error: (7, 'Failed to connect to 2001:4178:2:1269::fed2: Network is unreachable')

Identical results occur if I use HTTP_PROXY or nothing at all.

Additional info:
yum works fine (*if* I configure mirrorlist not to use https, but that's a different bug), and the system is fully updated. I specify the proxy in /etc/yum.conf, but yum will work without that if it gets the right environment variables.

Presumably, you'll get the same crash if the whole network connection goes away!

Comment 1 Till Maas 2012-03-26 16:41:06 UTC
Uh, I did not yet mean to submit my changes.

Can you please try to the variable "HTTPS_PROXY", note the extra "S" and the upper case of all characters, and maybe try both variables.

Comment 2 James Wilkinson 2012-03-27 09:05:57 UTC
Grrr. Sorry, I should have thought of that. It now no longer crashes. It doesn't report any RPMs (even though I have thunderbird-11.0-5.fc15.x86_64 installed, which is in F15 updates-testing, confirmed at http://koji.fedoraproject.org/koji/buildinfo?buildID=307579), but it doesn't crash.

HTTPS_PROXY=http://proxy:80/ HTTP_PROXY=http://proxy:80/ fedora-easy-karma --debug --installed-max-days=999
DEBUG: fedora_cert_error - timedelta: 0:00:00.000100
DEBUG: fas_username NameError - timedelta: 0:00:00.000103
Getting list of installed packages...
DEBUG: starting yum query - timedelta: 0:00:00.551577
Getting list of packages in updates-testing...
DEBUG: starting bodhi query - timedelta: 0:00:04.763629
DEBUG: reading ignore file /home/jamesw/.fedora-easy-karma/ignore.cpickle - timedelta: 0:00:35.340463
DEBUG: post processing bodhi query - timedelta: 0:00:00.017374
DEBUG: starting feedback loop - timedelta: 0:00:00.000891
DEBUG: makedirs OSError - timedelta: 0:00:00.000395 - timestamp not updated
DEBUG: writing ignore file - timedelta: 0:00:00.000433

and that's it.

Comment 3 Till Maas 2012-03-27 16:19:17 UTC
(In reply to comment #2)
> Grrr. Sorry, I should have thought of that. It now no longer crashes. It
> doesn't report any RPMs (even though I have thunderbird-11.0-5.fc15.x86_64
> installed, which is in F15 updates-testing, confirmed at
> http://koji.fedoraproject.org/koji/buildinfo?buildID=307579), but it doesn't
> crash.
> 
> HTTPS_PROXY=http://proxy:80/ HTTP_PROXY=http://proxy:80/ fedora-easy-karma

Can you please test with http_proxy in lower case. HTTPS_PROXY should work with either case.

Comment 4 James Wilkinson 2012-03-27 16:29:49 UTC
https_proxy=http://proxy:80/ http_proxy=http://proxy:80/ fedora-easy-karma --debug --installed-max-days=999
DEBUG: fedora_cert_error - timedelta: 0:00:00.000127
DEBUG: fas_username NameError - timedelta: 0:00:00.006319
Getting list of installed packages...
DEBUG: starting yum query - timedelta: 0:00:01.418440
Getting list of packages in updates-testing...
DEBUG: starting bodhi query - timedelta: 0:00:42.295505
DEBUG: reading ignore file /home/jamesw/.fedora-easy-karma/ignore.cpickle - timedelta: 0:00:17.890738
DEBUG: post processing bodhi query - timedelta: 0:00:00.043532
DEBUG: starting feedback loop - timedelta: 0:00:00.001171
DEBUG: makedirs OSError - timedelta: 0:00:00.000545 - timestamp not updated
DEBUG: writing ignore file - timedelta: 0:00:00.000582

Comment 5 James Wilkinson 2012-03-27 16:31:11 UTC
HTTPS_PROXY=http://proxy:80/ http_proxy=http://proxy:80/ fedora-easy-karma --debug --installed-max-days=999
DEBUG: fedora_cert_error - timedelta: 0:00:00.000100
DEBUG: fas_username NameError - timedelta: 0:00:00.000114
Getting list of installed packages...
DEBUG: starting yum query - timedelta: 0:00:00.634187
Getting list of packages in updates-testing...
DEBUG: starting bodhi query - timedelta: 0:00:13.585138
DEBUG: reading ignore file /home/jamesw/.fedora-easy-karma/ignore.cpickle - timedelta: 0:00:11.665563
DEBUG: post processing bodhi query - timedelta: 0:00:00.013302
DEBUG: starting feedback loop - timedelta: 0:00:00.000981
DEBUG: makedirs OSError - timedelta: 0:00:00.000475 - timestamp not updated
DEBUG: writing ignore file - timedelta: 0:00:00.000536

Comment 6 Till Maas 2012-03-27 16:42:53 UTC
Do you have other packages installed from testing except te thunderbird update? you won't be bugged for it anymore, because it is already requested to be pushed to stable:

https://admin.fedoraproject.org/updates/FEDORA-2012-3950/thunderbird-11.0-5.fc17,thunderbird-lightning-1.3-3.fc17?_csrf_token=3f38d1ed99b685fb491140918e9a84d8fb5830da

Comment 7 James Wilkinson 2012-03-28 16:38:33 UTC
Looks like my other testing packages have also been pushed too, then: I installed clamtk (which only went to testing overnight), and it now seems to be working properly.

Sorry for the noise, and thanks for the help,

James


Note You need to log in before you can comment on or make changes to this bug.