Bug 806875 - "Unable to unmarshall request body" thrown in tasks example ftest
"Unable to unmarshall request body" thrown in tasks example ftest
Status: CLOSED CANTFIX
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity high
: ---
: 2.0.0.GA
Assigned To: Marek Novotny
Ron Šmeral
Seam2.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 08:22 EDT by Ron Šmeral
Modified: 2016-10-31 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to the incompatibility between seam-resteasy-2.2.5.EAP5 and RESTEasy 2.3.1.GA, an unable to unmarshall request body error is thrown in the tasks example ftest. <procedure 1> is a workaround for this issue: 1. Exclude the following from the main deployment: - resteasy-jaxrs, - resteasy-jettison-provider, - resteasy-jaxb-provider 2. Exclude the following from the jboss-seam-tasks.war: - resteasy-jaxrs, - resteasy-jettison-provider, - resteasy-jaxb-provider, - resteasy-yaml-provider 3. Include the RESTEasy libraries in the EAR (these are bundled with Seam 2.2).
Story Points: ---
Clone Of:
Environment:
Fedora 16 64-bit, Mozilla Firefox 3.6.25, Oracle JDK 1.6.0_30, Seam 2.2.5.EAP5 (included in EAP 5.1.2.GA)
Last Closed: 2012-06-18 11:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (9.64 KB, text/plain)
2012-03-26 08:22 EDT, Ron Šmeral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-8315 Critical Closed "Unable to unmarshall request body" thrown in tasks example ftest 2014-06-25 09:46:57 EDT

  None (edit)
Description Ron Šmeral 2012-03-26 08:22:38 EDT
Created attachment 572746 [details]
Server log

Seam version: 2.2.5.EAP5 (included in EAP 5.1.2.GA)
The tasks example from Seam 2.2 was migrated to EAP6 according to the migration guide on Documentation-Stage (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Beta_Documentation/Migrate_Seam_22_Archives_to_JBoss_Enterprise_Application_Platform_6.html)
and the bug was verified to occur with EAP 6.0.0.ER1.
There is a patch available: https://gist.github.com/1949191

The ftest fails in 3 methods:
[testng] FAILED: undoTurtleTask
[testng] java.lang.AssertionError: There should NOT be a 'Undo this task' button for: Buy a turtle. expected:<false> but was:<true>
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.buttonMissing(SeleniumTasksTest.java:253)
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.undoTurtleTask(SeleniumTasksTest.java:116)
[testng] ... Removed 25 stack frames
[testng] FAILED: resolveTuringTask
[testng] java.lang.AssertionError: There should NOT be a 'Resolve this task' button for: Build the Turing machine. expected:<false> but was:<true>
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.buttonMissing(SeleniumTasksTest.java:253)
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.resolveTuringTask(SeleniumTasksTest.java:91)
[testng] ... Removed 25 stack frames
[testng] FAILED: createSeleniumTask
[testng] java.lang.AssertionError: There should be a 'Resolve this task' button for: Create selenium ftests for all available examples. expected:<true> but was:<false>
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.buttonPresent(SeleniumTasksTest.java:240)
[testng]     at org.jboss.seam.example.tasks.test.selenium.SeleniumTasksTest.createSeleniumTask(SeleniumTasksTest.java:149)
[testng] ... Removed 25 stack frames

Relevant part of server log attached.
Comment 1 Ron Šmeral 2012-03-26 13:24:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The cause of this bug is the incompatibility between seam-resteasy-2.2.5.EAP5 (included in EAP 5.1.2) and RESTEasy 2.3.1.GA (included in EAP 6).

This issue can be worked around by using jboss-deployment-structure.xml to exclude
- resteasy-jaxrs,
- resteasy-jettison-provider,
- resteasy-jaxb-provider
from the main deployment and
- resteasy-jaxrs,
- resteasy-jettison-provider,
- resteasy-jaxb-provider,
- resteasy-yaml-provider
from the jboss-seam-tasks.war, as described in https://issues.jboss.org/browse/JBPAPP-8315.
It is then necessary to include the RESTEasy libraries (bundled with Seam 2.2) in the EAR.
Comment 3 Rebecca Newton 2012-06-18 00:21:16 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,13 +1,12 @@
-The cause of this bug is the incompatibility between seam-resteasy-2.2.5.EAP5 (included in EAP 5.1.2) and RESTEasy 2.3.1.GA (included in EAP 6).
+Due to the incompatibility between seam-resteasy-2.2.5.EAP5 and RESTEasy 2.3.1.GA, an unable to unmarshall request body error is thrown in the tasks example ftest. <procedure 1> is a workaround for this issue:
 
-This issue can be worked around by using jboss-deployment-structure.xml to exclude
+1. Exclude the following from the main deployment:
 - resteasy-jaxrs,
 - resteasy-jettison-provider,
 - resteasy-jaxb-provider
-from the main deployment and
+2. Exclude the following from the jboss-seam-tasks.war:
 - resteasy-jaxrs,
 - resteasy-jettison-provider,
 - resteasy-jaxb-provider,
 - resteasy-yaml-provider
-from the jboss-seam-tasks.war, as described in https://issues.jboss.org/browse/JBPAPP-8315.
+3. Include the RESTEasy libraries in the EAR (these are bundled with Seam 2.2).-It is then necessary to include the RESTEasy libraries (bundled with Seam 2.2) in the EAR.
Comment 4 mark yarborough 2012-06-18 11:32:16 EDT
WFK 2.0 does not delivere Seam 2.2, however, these issues have already been documented in the EAP 6 release notes, so no need to duplicate each issue in WFk 2.0 release notes. However, we should include a pointer to the EAP 6 release notes to assist customers looking for Seam 2.2 bug information.
Comment 5 JBoss JIRA Server 2012-07-17 15:36:09 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8315 to Resolved
Comment 6 JBoss JIRA Server 2012-09-16 23:16:38 EDT
Russell Dickenson <rdickens@redhat.com> made a comment on jira JBPAPP-8315

I have reviewed this JIRA issue and the associated BZ ticket. From my perspective, this issue doesn't require a release notes entry, nor any documentation changes. Please advise me if I'm incorrect.
Comment 7 JBoss JIRA Server 2012-11-14 04:43:04 EST
Marek Schmidt <maschmid@redhat.com> updated the status of jira JBPAPP-8315 to Closed
Comment 8 JBoss JIRA Server 2012-11-14 04:43:04 EST
Marek Schmidt <maschmid@redhat.com> made a comment on jira JBPAPP-8315

Verified. The issue is listed in the EAP 6 Migration guide and the workaround works.

Note You need to log in before you can comment on or make changes to this bug.