Bug 806881 - The testsuite fails to shut down all the cache managers it has started
The testsuite fails to shut down all the cache managers it has started
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: unspecified (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 6.0.0
Assigned To: Tristan Tarrant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 08:29 EDT by Martin Gencur
Modified: 2012-08-15 12:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 07:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Gencur 2012-03-26 08:29:55 EDT
Description of problem:

I encountered this problem on all configurations (RHEL6, Solaris, Windows) and it effectively prevents us from running the testsuite during release testing.

The exceptions can be seen at:
https://hudson.qa.jboss.com/hudson/view/EDG6/view/EDG-REPORTS-FUNC/job/edg-60-community-testsuite-windows/jdk=java16_default,label=dev99-W2k8r2-x86_64/31/console

https://hudson.qa.jboss.com/hudson/view/EDG6/view/EDG-REPORTS-FUNC/job/edg-60-community-testsuite-rhel/13/jdk=openjdk-local,label=RHEL6/console

https://hudson.qa.jboss.com/hudson/view/EDG6/view/EDG-REPORTS-FUNC/job/edg-60-community-testsuite-solaris/34/jdk=java16_default,label=sol11_x86/

AFAIK, it is not related to specific tests. I saw this exception happening with various tests.

Typically the exception looks like this: 

2012-03-26 01:33:57,661 ERROR [TestCacheManagerFactory] (testng-RemoteAsyncAPITest) 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!! (testng-RemoteAsyncAPITest) Exiting because client.hotrod.RemoteAsyncAPITest has NOT shut down all the cache managers it has started !!!!!!!
!!!!!! (testng-RemoteAsyncAPITest) The still-running cacheManager was created here: org.infinispan.client.hotrod.RemoteAsyncAPITest.createCacheManager(RemoteAsyncAPITest.java:51) !!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Comment 1 mark yarborough 2012-03-29 07:55:37 EDT
Tristan reports this was a test bed configuration error (memory limitation)

Note You need to log in before you can comment on or make changes to this bug.