This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 80689 - kernel gives bogus "hda: DMA disabled" message.
kernel gives bogus "hda: DMA disabled" message.
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-29 17:18 EST by Hans de Goede
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2002-12-29 17:18:33 EST
kernel gives a bogus "hda: DMA disabled" message. I noticed that the 2.4.20-2.2
kernel gives a bogus hda: DMA disabled message, while it is actually enabled,
some scanning of the source found me this: in drivers/ide/ide.c
if (drive->autotune != 2) {
                /* DMA timings and setup moved to ide-probe.c */
                if (!driver->supports_dma && HWIF(drive)->ide_dma_off_quietly)
//                      HWIF(drive)->ide_dma_off_quietly(drive);
                        HWIF(drive)->ide_dma_off(drive);
                drive->dsc_overlap = (drive->next != drive && driver->supports_
                drive->nice1 = 1;
        }

Look at how for some reason a dma_off_quietly was changed into a dma_off without
beign quiet. Also notice that the code only checks for the availabality of
dma_off_quietly. I think this should be changed back otherwise you'll get lots
of support calls: why is my dma disabled???
Comment 1 Bill Nottingham 2003-01-01 01:01:10 EST
It actually is disabled when you get that message. There's just no message when
it reenables it.
Comment 2 Hans de Goede 2003-01-01 04:47:16 EST
I know (after reading the source) but since Joe the average user doesn't read
kernel source does he know?
Comment 3 Alan Cox 2003-06-05 09:36:23 EDT
This is fixed in the base code now

Note You need to log in before you can comment on or make changes to this bug.