Bug 8069 - syntax error in vim.h (vim 5.5)
syntax error in vim.h (vim 5.5)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: vim (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-30 12:48 EST by trent jarvi
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-06 12:18:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description trent jarvi 1999-12-30 12:48:57 EST
-- sent to Bram@vim.org also

--- vim-5.5/src/vim.h   Thu Sep  9 09:13:43 1999
+++ house-vim-5.5/src/vim.h     Thu Dec 30 09:54:11 1999
@@ -26,7 +26,7 @@
  * test program.  Other items from configure may also be wrong then!
  */
 # if (SIZEOF_INT == 0)
-    Error: configure did not run properly.  Check config.log.
+#error    Error: configure did not run properly.  Check config.log.
 # endif
 #endif
Comment 1 trent jarvi 2000-01-02 13:36:59 EST
Bram:

I submitted the patch to redhat also.  Maybe its best to have
distros keep a seperate patch outside of the prestine source
in the situation you describe.

The error is caused by a bad system setup.

I was just trying to reduce 560 lines of meaningless gcc warnings
and errors to 1 coherent error.  If some preprocessors cant handle
it I can see your point.  On linux #error makes more sense.
Packages are an easy way to deal with this issue.

Trent Jarvi
trentjarvi@yahoo.com

--- Bram Moolenaar <Bram@moolenaar.net> wrote:
>
> Trent -
>
> > --- vim-5.5/src/vim.h   Thu Sep  9 09:13:43 1999
> > +++ house-vim-5.5/src/vim.h     Thu Dec 30 09:54:11 1999
> > @@ -26,7 +26,7 @@
> >   * test program.  Other items from configure may also be wrong then!
> >   */
> >  # if (SIZEOF_INT == 0)
> > -    Error: configure did not run properly.  Check config.log.
> > +#error    Error: configure did not run properly.  Check config.log.
> >  # endif
> >  #endif
>
> That's how it was before, but this caused trouble for some compilers.  Did you
> have trouble with how it is now?
>
> - Bram
>
Comment 2 trent jarvi 2000-01-02 18:34:59 EST
[I guess I should mention this all started with configure failing to
write the test file for sizeof(int) on a near full fs.]

--- Bram Moolenaar <Bram@moolenaar.net> wrote:
>
> > I submitted the patch to redhat also.  Maybe its best to have
> > distros keep a seperate patch outside of the prestine source
> > in the situation you describe.
>
> It's alright if this is patched in a Linux distribution where gcc is always
> used.
Comment 3 Bernhard Rosenkraenzer 2000-01-06 12:18:59 EST
I don't think this needs to be fixed - sizeof(int) is not 0 on Linux, so first
of all you aren't getting to this place unless something's very wrong.
Also, both versions will generate an error, and point you to the same place.

Note You need to log in before you can comment on or make changes to this bug.