Bug 806916 - REST API: SetupNetworks missing action link
REST API: SetupNetworks missing action link
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Yaniv Kaul
infra network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 09:51 EDT by Avi Tal
Modified: 2016-04-22 00:59 EDT (History)
13 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Tal 2012-03-26 09:51:18 EDT
Description of problem:
htttp://engine:port/hosts/{host id}/nics/setupnetworks
This action link is missing under /nics

Exists:
<host_nics>
    <host_nic>
        ...
    </host_nic>
    <host_nic>
        ...
    </host_nic>
</host_nics>

--
should look like:
<host_nics>
    <actions>
        <link href='.../nics/setupnetworks' rel='setupnetworks' />
    </actions>
    <host_nic>
        ...
    </host_nic>
    <host_nic>
        ...
    </host_nic>
</host_nics>
Comment 4 Avi Tal 2012-07-26 05:45:16 EDT
Adding TesBlocker because it actually blocked us from testing SetupNetworks in automation framework.
Automation framework automatically generated data structures from XSD.
Missing actions for nics collection leads for missing SetupNEtworks action for nics data structure object.

BTW, the common use cases in automation is to automatically generate objects from XSD so i suspect many API users will scream this issue.
Comment 6 Ori Liel 2012-08-01 09:02:54 EDT
patch posted to gerrit, http://gerrit.ovirt.org/#/c/6816/
Comment 7 Michael Pasternak 2012-08-23 05:40:27 EDT
lowering priority as action code exist - QE can assume the url [1], and sdk has setupnetworks() method, so no blocker for testing.

(this is complex infrastructure change that may take time)

[1] /api/hosts/xxx/nics/setupnetwork
Comment 8 Michael Pasternak 2012-08-23 11:40:44 EDT
patch is NACK'ED at upstream.
Comment 9 Michael Pasternak 2012-08-25 10:31:57 EDT
http://gerrit.ovirt.org/#/c/7461/
Comment 11 Avi Tal 2012-08-30 12:03:34 EDT
Verify on SI16 - PASS

<host_nics>
 <actions>
  <link href="/hosts/1d1683d0-f2a7-11e1-b6f8-001a4a169763/nics/setupnetworks" rel="setupnetworks"/>
 </actions>
...
Comment 12 Avi Tal 2012-09-03 09:00:23 EDT
Reopen the bug due to missing entry point "/api"

href starts from "/hosts" instead of "/api/hosts" which lead to automation tests failure.
Comment 13 Avi Tal 2012-09-03 11:12:26 EDT
Wrong href example is in comment 11
Comment 15 Avi Tal 2012-09-05 09:38:00 EDT
Verify on si17 - PASS

<host_nics>
 <actions>
  <link href="/api/hosts/15bc90e8-f74d-11e1-a639-001a4a169763/nics/setupnetworks" rel="setupnetworks"/>
 </actions>
 ...

Note You need to log in before you can comment on or make changes to this bug.