Bug 806922 - perl-Socket-2.000-2 does not build in ARM Koji
perl-Socket-2.000-2 does not build in ARM Koji
Status: CLOSED DUPLICATE of bug 806543
Product: Fedora
Classification: Fedora
Component: perl-Socket (Show other bugs)
17
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 10:04 EDT by Petr Pisar
Modified: 2012-03-27 06:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 06:28:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 75668 None None None Never

  None (edit)
Description Petr Pisar 2012-03-26 10:04:20 EDT
Some t/sockaddr.t tests fails (http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=649875):

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/getaddrinfo.t .. ok
t/getnameinfo.t .. ok
t/ipv6_mreq.t .... ok
t/sockaddr.t ..... 
Failed 4/31 subtests 
t/Socket.t ....... ok
t/socketpair.t ... ok
Test Summary Report
-------------------
t/sockaddr.t   (Wstat: 11 Tests: 27 Failed: 0)
  Non-zero wait status: 11
  Parse errors: Bad plan.  You planned 31 tests but ran 27.
Files=6, Tests=124,  4 wallclock secs ( 0.20 usr  0.05 sys +  1.04 cusr  0.08 csys =  1.37 CPU)
Result: FAIL

I cannot reproduce it with up-to-date F17 ARMv7 machine locally. It fails in Koji only.
Comment 1 Petr Pisar 2012-03-26 10:24:05 EDT
The built root differences are
gcc: 4.7.0-0.20.fc17 vs. 4.7.0-1.fc17
rpm-build: 4.9.1.2-12.fc17 vs. 4.9.1.2-14.fc17
Comment 2 Petr Pisar 2012-03-26 10:39:01 EDT
Upgrading gcc and rpm-build did not help. Running tests verbosely shows last 4 test are missing:

[...]
ok 24 - pack_sockaddr_in6->unpack_sockaddr_in6 scope_id
ok 25 - pack_sockaddr_in6->unpack_sockaddr_in6 flowinfo
ok 26 - sockaddr_in6 in list context unpacks
ok 27 - sockaddr_in6 in scalar context packs
----
ok 28 - sockaddr_un can handle abstract AF_UNIX paths
ok 29 - sockaddr_un abstract address length
ok 30 - sockaddr_in deprecated form doesn't warn without lexical warnings
ok 31 - sockaddr_in deprecated form warns with lexical warnings
Comment 3 Petr Pisar 2012-03-26 11:56:24 EDT
Reproduced inside mock. This is probably well-know chroot-arm bug.
Comment 4 Petr Pisar 2012-03-26 12:05:04 EDT
Confirming segfault:

ok 27 - sockaddr_in6 in scalar context packs
chyby sestavení RPM:
/var/tmp/rpm-tmp.j6edts: line 31: 11777 Segmentation fault      perl -Iblib/lib -Iblib/arch t/sockaddr.t 2>&1
Comment 5 Petr Pisar 2012-03-27 05:14:14 EDT
After using patch from bug #806543, the mock build passes. I think this is the same issue unrelated to ARM architecture.
Comment 6 Petr Pisar 2012-03-27 06:28:04 EDT
It is.

*** This bug has been marked as a duplicate of bug 806543 ***

Note You need to log in before you can comment on or make changes to this bug.