Bug 806932 - ICMPv6 RA: ndisc_router_discovery() failed to add default route
ICMPv6 RA: ndisc_router_discovery() failed to add default route
Status: CLOSED DUPLICATE of bug 785772
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 10:30 EDT by Yann Droneaud
Modified: 2012-04-19 17:18 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 17:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (51.43 KB, application/x-gzip)
2012-03-26 10:30 EDT, Yann Droneaud
no flags Details
log of a a tcpdump ip6 session (12.60 KB, text/plain)
2012-03-26 11:13 EDT, Yann Droneaud
no flags Details
NetworkManager install log (6.15 KB, text/plain)
2012-03-27 14:34 EDT, Yann Droneaud
no flags Details
/var/log/messages (8.21 KB, text/plain)
2012-04-02 05:51 EDT, Yann Droneaud
no flags Details

  None (edit)
Description Yann Droneaud 2012-03-26 10:30:13 EDT
Created attachment 572767 [details]
/var/log/messages

It seems that, with the latest kernel, my network connection (Ethernet 100BaseT) is unstable:

The connection is "disconnected" every 10 minutes interval according to NetworkManager (with a notification on screen).


I'm using
    kernel-3.3.0-4.fc16.x86_64
    NetworkManager-0.9.2-1.fc16.x86_64.

My network interface is a
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)


My computer is connected to a FreeBox v5 ADSL router, which provides "native" IPv6 broadband access.
Comment 1 Yann Droneaud 2012-03-26 11:13:42 EDT
Created attachment 572778 [details]
log of a a tcpdump ip6 session
Comment 2 Neil Horman 2012-03-26 11:38:15 EDT
please see bz 785772.  Upgrading to the latest NM in rawhide fixes this issue.
Comment 3 Yann Droneaud 2012-03-26 14:52:34 EDT
I'm using Fedora 16. Installing NetworkManager from Rawhide require too much dependencies to be installed alone safely.

Is it possible to have a test update package ?
Comment 4 Neil Horman 2012-03-27 09:03:04 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=3936339

There you go, thats the rawhide NetworkManager built for f16.  

If you don't want to install that, you can also set your NM IPv6 configuration for all your interfaces to 'ignore'.  That should also fix the problem.
Comment 5 Yann Droneaud 2012-03-27 14:32:52 EDT
(In reply to comment #4)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3936339
> 
> There you go, thats the rawhide NetworkManager built for f16.  
> 

Thanks a lot for the packages.

I tried to install them but updated NetworkManager-gnome is missing.
Comment 6 Yann Droneaud 2012-03-27 14:34:12 EDT
Created attachment 573150 [details]
NetworkManager install log

(In reply to comment #5)
> 
> I tried to install them but updated NetworkManager-gnome is missing.

Here's the log if needed.
Comment 7 Neil Horman 2012-03-28 12:44:27 EDT
Thanks, not sure whats going on there.  I'll have to figure that out.  The spec file isn't explicitly Required:-ing that package.  

While I figure it out, please just set the interface settings for the interface in questions for IPv6 to Ignore or Disable, that will provide an equally good solution.
Comment 8 Jirka Klimes 2012-03-30 06:31:13 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=3936339
> > 
> > There you go, thats the rawhide NetworkManager built for f16.  
> > 
> 
> Thanks a lot for the packages.
> 
> I tried to install them but updated NetworkManager-gnome is missing.

Please try F16 update here (it's not in stable at the time of this posting)
http://koji.fedoraproject.org/koji/buildinfo?buildID=310135
Comment 9 Nicolas PENINGUY 2012-04-01 03:15:13 EDT
I also have the same problem, but the updated NetworkManager doesn't seem to help:

# yum info NetworkManager
Installed Packages
Name        : NetworkManager
Arch        : x86_64
Epoch       : 1
Version     : 0.9.4
Release     : 1.git20120328.fc16
Size        : 6.7 M
Repo        : installed
From repo   : updates-testing


Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

I have a "Freebox v6" ADSL router.
Comment 10 Yann Droneaud 2012-04-02 05:51:17 EDT
Created attachment 574435 [details]
/var/log/messages

After installing the provided packages, I'm still having the problem.

See this in the log.

Additionally, I'm hitting bug #799591 .
Comment 11 Neil Horman 2012-04-02 12:47:24 EDT
Did you all make sure you're configuration for ipv6 in NM hadn't reverted to automatic or dhcp?
Comment 12 Yann Droneaud 2012-04-02 13:00:53 EDT
(In reply to comment #11)
> Did you all make sure you're configuration for ipv6 in NM hadn't reverted to
> automatic or dhcp?

After installing the provided package here, I've checked that ipv6 configuration is in "automatic" mode. And it's still in "automatic" mode.
Comment 13 Neil Horman 2012-04-02 13:06:04 EDT
no, I'm asking if it wasn't in automatic mode previously.  If its in automatic now, you need to move it to ignore or disabled mode.  the rawhide NM has fixed this problem for some, but others still need to explicitly disable NM's ipv6 handling if they use SLAAC at the moment.
Comment 14 Yann Droneaud 2012-04-02 13:51:44 EDT
(In reply to comment #13)
> no, I'm asking if it wasn't in automatic mode previously.  If its in automatic
> now, you need to move it to ignore or disabled mode.  the rawhide NM has fixed
> this problem for some, but others still need to explicitly disable NM's ipv6
> handling if they use SLAAC at the moment.

If "ignore" or "disable" is still required, the updated NM packages are not fixing the problem as expected.

So I'm going to switch from "automatic" (the current and previous mode) to "ignore" which was proven to workaround the problem.
Comment 15 Neil Horman 2012-04-03 06:55:20 EDT
 As noted above some people have this problem automatically fixed when using the latest NM, others dont.  I'm still trying to figure out what the difference between the two is.

Given that this thread seems to contain people in the latter group, I'll reassign this over to NM for a closer look.
Comment 16 Dan Winship 2012-04-19 17:18:04 EDT

*** This bug has been marked as a duplicate of bug 785772 ***

Note You need to log in before you can comment on or make changes to this bug.