Bug 806984 - libvirt doesn't fill in <console> pty path for xen guest, virsh console errors with: Unable to open stream for '(null)': Bad address
libvirt doesn't fill in <console> pty path for xen guest, virsh console error...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 13:06 EDT by WSchleicher
Modified: 2012-06-06 07:22 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 07:22:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-install logfile (6.36 KB, text/plain)
2012-03-26 13:07 EDT, WSchleicher
no flags Details
logfile 1 (8.49 KB, text/plain)
2012-03-26 13:20 EDT, WSchleicher
no flags Details
logfile 2 (13.11 KB, text/plain)
2012-03-26 13:21 EDT, WSchleicher
no flags Details

  None (edit)
Description WSchleicher 2012-03-26 13:06:35 EDT
Description of problem:
error: unable to open stream for '(null)': Bad address
-> Unable to install pv guest (sl 6.2) on fedora domain0 (fedora 17 beta rc2)

Version-Release number of selected component (if applicable):
python-virtinst 0.600.1-1.fc17
kernel-PAE 3.3.0-5.fc17
xen 4.1.2-13.fc17

How reproducible:
- installing current fedora 17 (alpha, beta)
- installing xen
- rebooting in xen environment
- ensure that xen domain 0 is running (xl list) 0.5 from 2 GB reserved for dom0
- trying to install guest (domU) from network location

-> virt-install --connect xen:/// -n server_xen_232 -f /virtual/xen/server_xen_232.img -s 6.0 -r 512 --vcpus=1 --paravirt --uuid=00000192-0168-0000-0206-001921680232 -l http://192.168.0.250/el6-32 --virt-type=xen --os-type=linux --os-variant=rhel6 -x "ks=http://192.168.0.250/el6-xenoss-srv232.cfg i686 ip=192.168.0.232 netmask=255.255.255.0 gateway=192.168.0.1 dns=192.168.0.1 console=hvc0 earlyprintk=xen" --graphics none --debug

--> Connected to domain server_xen_232
--> Escape character is ...
--> error: unable to open stream for '(null)': Bad address

Steps to Reproduce:
1.
2.
3.
see above
  
Actual results:
Installation stops (xml file is created) and reports errormessage as listed above. Domain installation is reported to be in progress... but furthermore there's no console connection possible.

Expected results:
Started guest should continue download network (xen)bootimage and installing rpms.

Additional info:
Same procedure works fine with fedora 15+16.

Not sure if this is a python-virtinst package problem only or a xen error in general!
Comment 1 WSchleicher 2012-03-26 13:07:32 EDT
Created attachment 572814 [details]
virt-install logfile
Comment 2 WSchleicher 2012-03-26 13:20:42 EDT
Created attachment 572816 [details]
logfile 1

attaching some more xen related logfiles.
Comment 3 WSchleicher 2012-03-26 13:21:21 EDT
Created attachment 572817 [details]
logfile 2

attaching some more xen related logfiles.
Comment 4 Cole Robinson 2012-04-09 20:59:30 EDT
Hmm, looks like libvirt is generating console XML like:

    <console type='pty'>
      <target type='xen' port='0'/>
    </console>

There should be a pty path in there. That error message:

    error: Unable to open stream for '(null)': Bad address

Is coming from virsh console. So this is a libvirt issue
Comment 5 WSchleicher 2012-04-11 05:19:52 EDT
Thanks for additional info and bug redirection.

Today, I installed 17-Beta.RC4 which includes latest "libvirt-0.9.11-1.fc17.i686" and still faced the same problem. Seems that from first Fedora 17-TC libvirt does not play together with python-virtinst tool.

Meanwhile I used xen old deployment style (xl create -c domu.cfg) with creates a working domU image but does not include 'smart configuration switches' as offered by python-virtinst (xml).

Hopefully we'll see a working solution when Fedora 17 Final is released.
Comment 6 WSchleicher 2012-05-25 17:17:54 EDT
If current 17.RC4 will become GOLD/FINAL release the reported problem still exists...

No sure if fedora distribution is a suitable choice when it comes to xen as bare metal hypervisor. B.t.w., after installing xen packages, fedora's bootloader configuration (grub2.cfg / grub-install) ist not modified to boot in xen-environment.
Comment 7 WSchleicher 2012-06-01 10:30:00 EDT
'Problem' solved, xenconsoled was not running... daemon had to be started by hand

Note You need to log in before you can comment on or make changes to this bug.