Bug 806986 - Subscription-Manager should refer to subscription name and product name
Subscription-Manager should refer to subscription name and product name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-03-26 13:15 EDT by Bryan Kearney
Modified: 2013-01-10 06:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Customer Portal SKU (107.73 KB, image/png)
2012-06-28 12:52 EDT, Amanda Carter
no flags Details
New Filed SKU displayed in "My Subscriptions" and "All Available Subscriptions" (144.33 KB, image/png)
2012-07-09 18:26 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Bryan Kearney 2012-03-26 13:15:19 EDT
The CLI references Product Name for list --available, list --consumed, and list --installed. Product Name and Product ID should only be used to reference engineering products.. not subscription. Please change the output of --available and --consumed to be "Subscription Name" or just "Name"
Comment 1 RHEL Product and Program Management 2012-04-02 06:50:11 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Shwetha Kallesh 2012-06-21 01:23:21 EDT
Verified!!

RPM used:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.4-1.git.0.5943ee7.el5
subscription-manager-1.0.4-1.git.0.5943ee7.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.0.5943ee7.el5
subscription-manager-migration-1.0.4-1.git.0.5943ee7.el5


[root@dhcp201-196 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Product Subscriptions
+-------------------------------------------+

Subscription Name:    	Awesome OS with unlimited virtual guests
Provides:             	Awesome OS Server Bits
Contract:             	108
Account:              	12331131231
Serial Number:        	2025920196398414954
Active:               	True
Quantity Used:        	1
Service Level:        	None
Service Type:         	None
Starts:               	06/19/2012
Ends:                 	06/19/2013



[root@dhcp201-196 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

Subscription Name:    	Awesome OS Modifier
Pool Id:              	8ac149343804aed1013804afd62a0315
Quantity:             	5
Service Level:        	
Service Type:         	
Multi-Entitlement:    	No
Ends:                 	06/19/2013
Machine Type:         	physical
Comment 3 John Sefler 2012-06-28 12:04:20 EDT
As a result of this change, there is no longer a "Product ID" field in the list of available subscriptions.  This is somewhat problematic since "Product ID" (also known by the IT group as SKU) was the value used to identify the subscriptions for testing.  The "Subscription Name" is just a name and is not enough information for the SKU testing team in China to confidently identify the subscription pool generated for a particular SKU test.

1. I vote we bring back the "Product ID" field in the list of available subscriptions.  However, I also believe that "Product ID" is the wrong label to used since it is confusing with the "Product ID" of an installed product cert.  Amanada has always called this field SKU.  How about "SKU" or "Subscription ID"?
Suggestions Amanda?

2. Since we want to remove 'Product' from the Subscriptions list, I suggest changing the banner on subscription-manager list --consumed to remove the word "Product"....
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Moving back to NEW status for a revisit.
Comment 4 Amanda Carter 2012-06-28 12:52:59 EDT
Created attachment 595092 [details]
Customer Portal SKU
Comment 5 Amanda Carter 2012-06-28 13:05:18 EDT
I wouldn't suggest designing a feature just for our test team. I'd like to get feedback from UX on this one. If there is value in showing the customer sku, great (though most customers don't know what that is). If not, than the testing team may need to work out another solution (like using contract number). If it is desirable, fwiw, the Customer Portal displays 'SKU'. See attached.
Comment 10 James Bowes 2012-07-06 14:44:36 EDT
Changes made in master, 9d4d24.

SKU is visible in the gui and cli for both available subs, and consumed entitlements.
Comment 11 Sharath Dwaral 2012-07-09 18:26:09 EDT
Created attachment 597163 [details]
New Filed SKU displayed in "My Subscriptions" and "All Available Subscriptions"

Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.8-1.git.14.dfc8438.el5
python-rhsm-1.0.3-1.git.0.583d26c.el5
subscription-manager-firstboot-1.0.8-1.git.14.dfc8438.el5
subscription-manager-1.0.8-1.git.14.dfc8438.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.8-1.git.14.dfc8438.el5

Result:

# subscription-manager register --org admin
Username: testuser1
Password: 
The system has been registered with id: c4f881ab-a87d-4146-a650-1a258c4a6eae 
# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Awesome OS Server Basic
SKU:                  	awesomeos-server-basic
Pool Id:              	8a90f824386bfa3001386bfaff3102ab
Quantity:             	5
Service Level:        	None
Service Type:         	Self-Support
Multi-Entitlement:    	No
Ends:                 	07/08/2013
Machine Type:         	physical

Subscription Name:    	Awesome OS Server Basic
SKU:                  	awesomeos-server-basic
Pool Id:              	8a90f824386bfa3001386bfaff5502b8
Quantity:             	10
Service Level:        	None
Service Type:         	Self-Support
Multi-Entitlement:    	No
Ends:                 	07/08/2013
Machine Type:         	physical



# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Awesome OS Server Bundled (2 Sockets, Standard Support)
Provides:             	Clustering Bits
                      	Awesome OS Server Bits
                      	Shared Storage Bits
                      	Management Bits
                      	Large File Support Bits
                      	Load Balancing Bits
SKU:                  	awesomeos-server-2-socket-std
Contract:             	37
Account:              	12331131231
Serial Number:        	60243626245270285
Active:               	True
Quantity Used:        	1
Service Level:        	Standard
Service Type:         	L1-L3
Starts:               	07/08/2012
Ends:                 	07/08/2013


Moving Bug VERIFIED
Comment 13 errata-xmlrpc 2013-01-07 22:49:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.