Bug 807018 - ipa config-mod should not be allowed to modify certificate subject base
ipa config-mod should not be allowed to modify certificate subject base
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 15:10 EDT by Jenny Galipeau
Modified: 2013-02-21 04:10 EST (History)
1 user (show)

See Also:
Fixed In Version: ipa-3.0.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:10:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2012-03-26 15:10:15 EDT
Description of problem:
You should not be able to modify certificate subject base, it is set on install and not configurable

ipa config-mod --setattr=ipacertificatesubjectbase="OU=Bogus"  is successful

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-5.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. kinit admin
2.ipa config-mod --setattr=ipacertificatesubjectbase="OU=Bogus"
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Kosek 2012-03-27 07:00:48 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2580
Comment 2 Martin Kosek 2012-05-29 03:25:31 EDT
Fixed upstream:
master: https://fedorahosted.org/freeipa/changeset/1af36da933cd3c788e3a48257e2f5c286e985e22
Comment 5 Namita Soman 2013-01-14 22:16:56 EST
Verified using ipa-server.x86_64 0:3.0.0-21.el6

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipaconfig_addaddtr negative test - ipacertificatesubjectbase only one allowed
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [16:13:08] ::  Executing: ipa config-mod --addattr=ipacertificatesubjectbase=O=DOMAIN.COM
ipa: ERROR: invalid 'ipacertificatesubjectbase': attribute is not configurable
:: [16:13:09] ::  "ipa config-mod --addattr=ipacertificatesubjectbase=O=DOMAIN.COM" failed as expected.
:: [   PASS   ] :: Error message as expected: ipa: ERROR: invalid 'ipacertificatesubjectbase': attribute is not configurable
:: [   PASS   ] :: Verify expected error message.
:: [16:13:10] ::  Verifies bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=807018
'f470a471-0e82-4a1a-ac50-621c66ecb702'
ipaconfig-addaddtr-negative-test-ipacertificatesubjectbase-only-one-allowed result: PASS
Comment 7 errata-xmlrpc 2013-02-21 04:10:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0528.html

Note You need to log in before you can comment on or make changes to this bug.