Bug 807058 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesses on the file .
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesse...
Status: CLOSED DUPLICATE of bug 806470
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:083d34eda8a36fa7287d45246fe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 17:42 EDT by Flóki Pálsson
Modified: 2012-03-27 02:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 02:49:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2012-03-26 17:42:20 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.x86_64
reason:         SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesses on the file .
time:           mán 26.mar 2012, 21:42:06 GMT

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesses on the file .
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow totem-video-thumbnailer to have getattr access on the  file
:Then you need to change the label on $FIX_TARGET_PATH
:Do
:# semanage fcontext -a -t FILE_TYPE '$FIX_TARGET_PATH'
:where FILE_TYPE is one of the following: xdm_tmp_t, user_home_type, sysctl_crypto_t, net_conf_t, cert_t, etc_t, user_tmp_t, logfile, user_tmp_type, gstreamer_home_t, sssd_public_t, abrt_t, lib_t, ld_so_t, xdm_home_t, cpu_online_t, abrt_helper_exec_t, thumb_tmp_t, user_home_t, krb5_conf_t, passwd_file_t, bin_t, locale_t, dosfs_t, etc_t, fonts_t, proc_t, thumb_t, sysfs_t, usr_t, textrel_shlib_t, rpm_script_tmp_t, user_tmp_t, audio_home_t, fonts_cache_t, ld_so_cache_t, abrt_var_cache_t, samba_var_t, thumb_exec_t, thumb_home_t, shell_exec_t, sosreport_tmp_t, rpm_tmp_t, net_conf_t, admin_home_t, abrt_var_run_t, data_home_t, user_cron_spool_t, krb5_host_rcache_t. 
:Then execute: 
:restorecon -v '$FIX_TARGET_PATH'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed getattr access on the  file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:default_t:s0
:Target Objects                 [ file ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.3.92-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.x86_64 #1 SMP Mon Mar 19
:                              03:03:39 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    mán 26.mar 2012, 21:41:02 GMT
:Last Seen                     mán 26.mar 2012, 21:41:32 GMT
:Local ID                      73e693e5-f0a2-4dbe-9ec4-fbb4bf1b8318
:
:Raw Audit Messages
:type=AVC msg=audit(1332798092.220:85): avc:  denied  { getattr } for  pid=2068 comm="totem-video-thu" path=2F6D6E742F746F6E6C6973742F746F6E6C6973742F4D50335F6CC3B6672F313063632F477265727465737420686974732F446F6E6E612E6D7033 dev="sdc1" ino=5071821 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1332798092.220:85): arch=x86_64 syscall=stat success=no exit=EACCES a0=205f720 a1=7fff271e94e0 a2=7fff271e94e0 a3=74726572472f6363 items=0 ppid=1506 pid=2068 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,default_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Flóki Pálsson 2012-03-26 17:44:04 EDT
see bug 806470
Comment 2 Miroslav Grepl 2012-03-27 02:49:18 EDT

*** This bug has been marked as a duplicate of bug 806470 ***

Note You need to log in before you can comment on or make changes to this bug.