Bug 80706 - hwbrowser minor bug and some suggestions
hwbrowser minor bug and some suggestions
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-30 02:17 EST by Jeff Silverman
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 14:26:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Silverman 2002-12-30 02:17:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020830

Description of problem:
I am unhappy with hwbrowser for three reasons:

1) It would be nice if it would output in ASCII, HTML, or XML in addition to the
graphical output (which is very nice)

2) It would be nice if it would tell you the CPU, RAM, and the chipset.

3) It would be nice if it was organized not only by categories, but also a tree
structured listing by bus.

Example:

Chipset
   CPU
   RAM
   PCI bridge
     IDE controller
       Primary master
       Primary slave
       Secondary master
       Secondary slave
     Floppy controller
       floppy drive
       floppy drive 
     Parallel printer port
       printer device
     UART
       Serial port 0
       serial port 1
     USB controller
       USB hub
         USB device
     Ethernet Card
       list of ethernet addresses and IP addresses (get from arp)
   ISA bridge
     Legacy device
   AGP video card
     Monitor

This really screams XML which has the ability to do endentured lists
very nicely.

4) On my server, a 100 MHz Pentium with 32 Mbytes of RAM, a 3C509 ethernet card,
and a Realtek RTL-8029(AS).  The RealTek shows up as /dev/eth when it should be
/dev/eth0.  The 3Com 3C509 doesn't show up at all, but it is clearly there. 
lsmod shows that the 3c509 module is loaded.

I hate to bellyache - I **love** RedHat 8.0!



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use a machine with a 3C509 ethernet card and a Realtek 8029(AS)
2.run /usr/bin/hwbrowser as root or using sudo
3.
    

Actual Results:  I see a network card, Realtek 8029(AS) at /dev/eth

Expected Results:  I expected to see two network cards, Realtek 8029(AS) at
/dev/eth0 and a 3Com 3C509 at /dev/eth1

Additional info:

Here is my /etc/modules.conf:
[jeffs@angel jeffs]$ more /etc/modules.conf
alias eth0 ne2k-pci
alias eth1 3c509
alias parport_lowlevel parport_pc
alias net-pf-5 appletalk
Here are my modules:
[jeffs@angel jeffs]$ /sbin/lsmod
Module                  Size  Used by    Not tainted
nfsd                   73232   8 (autoclean)
lockd                  53488   1 (autoclean) [nfsd]
sunrpc                 75356   1 (autoclean) [nfsd lockd]
autofs                 12228   0 (autoclean) (unused)
3c509                  11732   1
ne2k-pci                6752   1
8390                    7788   0 [ne2k-pci]
ipchains               39720  73
ext3                   64224   4
jbd                    48180   4 [ext3]
Comment 1 Miloslav Trmac 2002-12-30 14:36:02 EST
1) kudzu --help
3) Some variands of 3c509 are ISA PnP, some not, AFAIK.
   (All of them support a 3c509-specific protocol, but adding
    this to kudzu is probably not worth it nowadays)
   See /proc/isapnp to check the card supports PnP.
Comment 2 Brent Fox 2003-01-13 23:58:45 EST
jeffs: can you attach the output of 'cat /proc/isapnp'?
Comment 3 Jeff Silverman 2003-01-14 01:45:36 EST
There is no /proc/isapnp  I do not understand why not.

[jeffs@angel jeffs]$ sudo ls /proc/*pnp
Password:
ls: /proc/*pnp: No such file or directory
[jeffs@angel jeffs]$ sudo ls -a /proc
.      17593  29753  4943  7     744  902      driver       loadavg     stat
..     17594  29754  5     703   745  990      execdomains  locks       swaps
1      18948  29755  536   7166  746  991      fb           mdstat      sys
105    2      29759  540   717   747  992      filesystems  meminfo     sysvipc
106    26209  29760  552   7193  750  993      fs           misc        tty
107    26582  3      6     7195  751  994      ide          modules     uptime
12     26782  31520  633   7196  755  995      interrupts   mounts      version
17587  26783  31621  650   7197  8    apm      iomem        net
17588  26784  31645  686   736   808  bus      ioports      partitions
17589  26785  31647  688   740   859  cmdline  irq          pci
17590  27222  31649  689   741   868  cpuinfo  kcore        self
17591  27232  31692  690   742   872  devices  kmsg         slabinfo
17592  27260  4      691   743   890  dma      ksyms        speakup
[jeffs@angel jeffs]$ 
Comment 4 Brent Fox 2003-01-14 02:08:35 EST
Try this:
1) As root, run 'python'.  Then enter the following lines:
2) >>> import kudzu
3) >>> card = kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_PCI, kudzu.PROBE_ALL)
4) >>> print card

What does the output of that look like?
Comment 5 Jeff Silverman 2003-01-14 02:24:53 EST
[jeffs@angel jeffs]$ python
Python 2.2.1 (#1, Aug 30 2002, 12:15:30) 
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> card = kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_PCI, kudzu.PROBE_ALL)
>>> print card
[Desc:           Realtek|RTL-8029(AS)
Driver:         ne2k-pci
Device:         eth
]
>>> 
Comment 6 Brent Fox 2003-01-31 16:41:20 EST
Ok, I think I can explain what is going on here.  

For one, ethernet devices are identified by kudzu as 'eth', not 'eth0' or
'eth1'.  See bug #82442 for more information about the reasons for this.

Secondly, kudzu is not detecting your 3Com card and I'm guessing that's because
it is an ISApnp device, and kudzu is only looking for network cards on the PCI
bus.  

Try running this probe on the ISA bus:

1) As root, run 'python'.  Then enter the following lines:
2) >>> import kudzu
3) >>> card = kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_ISAPNP, kudzu.PROBE_ALL)
4) >>> print card

What does that say?
Comment 7 Brent Fox 2003-02-07 00:25:13 EST
ping?
Comment 8 Jeff Silverman 2003-02-07 02:11:33 EST
Pong!
Looks like I missed a message somewhere, sorry.



[root@angel awstats]# python
Python 2.2.1 (#1, Aug 30 2002, 12:15:30) 
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> card = kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_ISAPNP, kudzu.PROBE_ALL)
>>> print card
[]
>>> quit
'Use Ctrl-D (i.e. EOF) to exit.'
>>> 
[root@angel awstats]# 
Comment 9 Brent Fox 2003-02-07 14:26:21 EST
Well, it looks like the ISA card can't be detected by kudzu.  I don't think
there's anything I can do about that.  If kudzu can't detect the card, then
hwbrowser has no other way of getting the information to display.  Closing as
'wontfix'.

Note You need to log in before you can comment on or make changes to this bug.