Bug 807102 - one usb-storage disk miss to be detected with usb-hub adding automatically in windows guest
one usb-storage disk miss to be detected with usb-hub adding automatically in...
Status: CLOSED DUPLICATE of bug 796118
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 22:36 EDT by Sibiao Luo
Modified: 2012-03-29 03:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 03:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2012-03-26 22:36:25 EDT
Description of problem:
assigning lots of usb devices to guest, usb-hub will be added automatically, but there is one usb-storage disk left behind, miss to be detected in the windows guest.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.265.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-12.el6.x86_64 
guest info:
guest_name: win7sp1-64
virtio-win: virtio-win-prewhql-0.1-24 

How reproducible:
100%

Steps to Reproduce:
1.boot guest with "-readconfig ich9-ehci-uhci.cfg", assign 16 of usb devices and let the usb-hub add automatically.
CLI: # /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Penryn -enable-kvm -m 2048 -smp 2,sockets=1,cores=2,threads=1 -name win7-sp1-64 -uuid `uuidgen` -drive file=/home/win7sp1-virtio-64-copy.raw,format=raw,if=none,id=drive-virtio-disk0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,scsi=off,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=05:1a:4a:02:0b:46,bus=pci.0,bootindex=2 -device virtio-balloon-pci,id=ballooning -spice disable-ticketing,port=5931 -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -readconfig /home/ich9-ehci-uhci.cfg -monitor stdio -drive file=usb-storage1.qcow2,if=none,id=storage1,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage1,id=usb-storage1 -drive file=usb-storage2.qcow2,if=none,id=storage2,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage2,id=usb-storage2 -drive file=usb-storage3.qcow2,if=none,id=storage3,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage3,id=usb-storage3 -drive file=usb-storage4.qcow2,if=none,id=storage4,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage4,id=usb-storage4 -drive file=usb-storage5.qcow2,if=none,id=storage5,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage5,id=usb-storage5 -drive file=usb-storage6.qcow2,if=none,id=storage6,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage6,id=usb-storage6 -drive file=usb-storage7.qcow2,if=none,id=storage7,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage7,id=usb-storage7 -drive file=usb-storage8.qcow2,if=none,id=storage8,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage8,id=usb-storage8 -drive file=usb-storage9.qcow2,if=none,id=storage9,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage9,id=usb-storage9 -drive file=usb-storage10.qcow2,if=none,id=storage10,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage10,id=usb-storage10 -drive file=usb-storage11.qcow2,if=none,id=storage11,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage11,id=usb-storage11 -drive file=usb-storage12.qcow2,if=none,id=storage12,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage12,id=usb-storage12 -drive file=usb-storage13.qcow2,if=none,id=storage13,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage13,id=usb-storage13 -drive file=usb-storage14.qcow2,if=none,id=storage14,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage14,id=usb-storage14 -drive file=usb-storage15.qcow2,if=none,id=storage15,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage15,id=usb-storage15 -drive file=usb-storage16.qcow2,if=none,id=storage16,media=disk,cache=none,format=qcow2 -device usb-storage,drive=storage16,id=usb-storage16
2.check the usb info in the monitor.
(qemu) info usb
  Device 0.6, Port 1, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.1, Port 2, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.3, Port 3, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.4, Port 4, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.5, Port 5, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.1, Port 6, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.2, Port 6.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.3, Port 6.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.14, Port 6.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.5, Port 6.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.6, Port 6.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.7, Port 6.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.8, Port 6.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.9, Port 6.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.15, Port 6.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.11, Port 6.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.10, Port 6.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.12, Port 6.8.4, Speed 12 Mb/s, Product QEMU USB MSD
3.initialize and format all the disks in the guest var "Computer---->Manage---->Disk Management".
 
Actual results:
after the step 3, only detect 15 usb-storage disks in the "Disk Management", and all the 15 usb-storage disks can be initialized and formatted successfully.
But there is one usb-storage disk left behind, miss to be detected in the windows guest, and i can find only 15 USB Mass Storage Devices in the "System device" form the "Device Manager".

Expected results:
should detect 16 usb-storage disks, and all the disks can be initialized and formatted successfully.

Additional info:
1.If i boot guest with "-readconfig ich9-ehci-uhci.cfg", assign 15 of usb devices in the step 1, only can detect 14 usb-storage disks after the step 3.
2.ich9-ehci-uhci.cfg can be found in:
http://git.engineering.redhat.com/?p=users/ehabkost/qemu-kvm-rhel6.git;a=blob;f=docs/ich9-ehci-uhci.cfg;hb=HEAD
Comment 2 Gerd Hoffmann 2012-03-27 06:54:37 EDT
Hmm, doesn't reproduce, works for me.
win7 guest sees all 16 usb disks just fine.
How big are your usb drives?  /me uses 256 MB
Comment 3 Sibiao Luo 2012-03-28 02:14:51 EDT
(In reply to comment #2)
> Hmm, doesn't reproduce, works for me.
> win7 guest sees all 16 usb disks just fine.
> How big are your usb drives?  /me uses 256 MB

Hi Gerd,

   I have recreated the usb-storage disks, each of them are 256MB, and retest it as the same steps, but still hit the issue. I boot the guest with 16 of usb devices, let the usb-hub add automatically, but can only detect 15 usb devices in the guest.

   By the way, i tried many times, and the test results as following:

--------------------------------------------
    how many add     |   how many detect
--------------------------------------------
         16          |       15                 
--------------------------------------------
         13          |       12                 
--------------------------------------------
         12          |       11                 
--------------------------------------------
          9          |        8                 
--------------------------------------------
          8          |        8                 
--------------------------------------------
          6          |        6                 
--------------------------------------------
          5          |        5                 
--------------------------------------------
Comment 4 Gerd Hoffmann 2012-03-28 11:56:26 EDT
Try 2.6.32-253.el6.x86_64 or newer.
Might be yet another dup of 796118.
Comment 5 Sibiao Luo 2012-03-28 23:50:02 EDT
(In reply to comment #4)
> Try 2.6.32-253.el6.x86_64 or newer.
> Might be yet another dup of 796118.

Hi Gerd,

   I have retested this issue on the 2.6.32-253.el6.x86_64 with the same steps assigned 16 of usb devices, the guest can detect the 16 usb-storage disks, and all the 16 usb-storage disks can be initialized and formatted successfully. 

   So, this issue have been fixed on the latest qemu-kvm version.

Thx. & Best wish
Comment 6 Gerd Hoffmann 2012-03-29 03:34:46 EDT

*** This bug has been marked as a duplicate of bug 796118 ***

Note You need to log in before you can comment on or make changes to this bug.