Bug 807144 - [Rest API] exit_code is empty in error message when trying to embed cartridges except mysql/jenkins-client to a scalable app
[Rest API] exit_code is empty in error message when trying to embed cartridge...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 03:36 EDT by Johnny Liu
Modified: 2012-04-13 14:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:31:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-03-27 03:36:33 EDT
Description of problem:
exit_code is empty in error message when trying to embed cartridges except mysql/jenkins-client to a scalable app

Version-Release number of selected component (if applicable):
devenv_1674

How reproducible:
Always

Steps to Reproduce:
1. Create a scalable app
2. Try to embed cartridges except mysql/jenkins-client to it
3.
  
Actual results:
exit-code is empty in the error message.
$ curl -k -X POST -H 'Accept: application/xml' -d cartridge=postgresql-8.4 --user jialiu@redhat.com:214214 https://ec2-23-20-26-98.compute-1.amazonaws.com/broker/rest/domains/jialiu/applications/myapp/cartridges
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>internal_server_error</status>
  <messages>
    <message>
      <field nil="true"></field>
      <severity>error</severity>
      <exit-code nil="true"></exit-code>
      <text>Failed to add postgresql-8.4 to application myapp due to postgresql-8.4 cannot be embedded in scalable app 'myapp'.</text>
    </message>
  </messages>
  <version>1.0</version>
  <data nil="true"></data>
  <type nil="true"></type>
</response>


Expected results:
exit-code should NOT be empty in the error message.

Additional info:
Comment 1 Rajat Chopra 2012-03-27 18:59:20 EDT
fixed with rev#369ff1754d5bd0e29a6d8fea0969a8b864c57316
Comment 2 Johnny Liu 2012-03-28 00:24:12 EDT
Verified this bug with devenv_1677, exit-code is shown up, but error text is not clear. I will file a new bug to track that issue, and verified this bug with PASS.
Comment 3 Johnny Liu 2012-03-28 00:24:54 EDT
$ curl -k -X POST -H 'Accept: application/xml' -d cartridge=postgresql-8.4 --user jialiu@redhat.com:xx https://ec2-50-17-96-240.compute-1.amazonaws.com/broker/rest/domains/jialiu/applications/myapp/cartridges
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>internal_server_error</status>
  <messages>
    <message>
      <text>Failed to add postgresql-8.4 to application myapp. Details : 
</text>
      <field nil="true"></field>
      <exit-code>108</exit-code>
      <severity>error</severity>
    </message>
  </messages>
  <data nil="true"></data>
  <type nil="true"></type>
  <version>1.0</version>
</response>

Note You need to log in before you can comment on or make changes to this bug.