Bug 807146 - snapshot_blkdev tab completion for device id missing
snapshot_blkdev tab completion for device id missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks: 806280
  Show dependency treegraph
 
Reported: 2012-03-27 03:44 EDT by Shaolong Hu
Modified: 2013-02-21 08:07 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.320.el6
Doc Type: Bug Fix
Doc Text:
The previous version of qemu was missing the auto-complete function for entering a snapshot_blkdev device ID. This issue is now fixed, and auto-complete works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 08:07:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-03-27 03:44:21 EDT
Description of problem:
--------------------------
after input "snapshot_blkdev" in qemu monitor, press "Tab", device id list shows and there is a completion function when enter part of device id string, in recent version this function misses, worth fixing? 


Version-Release number of selected component (if applicable):
qemu 265rhev

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 4 Jeff Cody 2012-06-26 14:01:14 EDT
Upstream commit 3b6dbf277232920a6463fc01d630e4d9dc378ef6 fixes this.  We should probably also bring along 03a63484a6978f68caff087bbaabcd1d383563af.  Both are clean cherry-picks.
Comment 10 Shaolong Hu 2012-10-26 01:15:55 EDT
Verified on qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64:

Completion function is back.
Comment 12 errata-xmlrpc 2013-02-21 08:07:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0543.html

Note You need to log in before you can comment on or make changes to this bug.