Bug 807149 - [abrt] Zim-0.55-1.fc16: pageview.py:2549:paste_clipboard:AttributeError: 'NoneType' object has no attribute 'resolve_images'
[abrt] Zim-0.55-1.fc16: pageview.py:2549:paste_clipboard:AttributeError: 'Non...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:252927c8f5f9981d1839d375007...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 03:47 EDT by Pierguido Lambri
Modified: 2012-11-28 06:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 06:58:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1005111 None None None Never

  None (edit)
Description Pierguido Lambri 2012-03-27 03:47:45 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/zim
comment:        Creating new page
executable:     /usr/bin/zim
kernel:         3.3.0-4.fc16.x86_64
reason:         pageview.py:2549:paste_clipboard:AttributeError: 'NoneType' object has no attribute 'resolve_images'
time:           Tue 27 Mar 2012 08:13:56 BST
uid:            1000
username:       pier

backtrace:
:pageview.py:2549:paste_clipboard:AttributeError: 'NoneType' object has no attribute 'resolve_images'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 3287, in do_button_press_event
:    buffer.paste_clipboard(SelectionClipboard, iter, self.get_editable())
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2549, in paste_clipboard
:    parsetree.resolve_images(self.notebook, self.page)
:AttributeError: 'NoneType' object has no attribute 'resolve_images'
:
:Local variables in innermost frame:
:self: <TextBuffer object at 0x2ca4410 (zim+gui+pageview+TextBuffer at 0x2db5300)>
:iter: <GtkTextIter at 0x2e7a0a0>
:mark: <gtk.TextMark object at 0x2c9bd20 (GtkTextMark at 0x2e5f360)>
:clipboard: <zim.gui.clipboard.ClipboardManager object at 0x297d190>
:parsetree: None
:default_editable: True

smolt_data:
:
:
:General
:=================================
:UUID: 087f8790-876c-4894-a14b-f21c3186f344
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: x86_64
:BogoMIPS: 5054.19
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 540  @ 2.53GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2534
:System Memory: 3753
:System Swap: 4093
:Vendor: LENOVO
:System: 2537CT4 ThinkPad T410
:Form factor: Notebook
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4480:57904:6058:8500) pci, None, BASE, Memory Stick Host Controller
:(4480:59442:6058:8502) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8595) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:6058:8531) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:70:6058:8538) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_piernb-root / ext4 4096 4096 12778715 8313087 7672883 3203072 2961358 2961358
:/dev/mapper/luks-e8fd0e87-c105-4682-8678-c38951f0c26e /home ext4 4096 4096 25044898 9440024 8185855 6275072 5561488 5561488
:
Comment 1 Pierguido Lambri 2012-05-16 11:56:58 EDT
Editing a page

Package: Zim-0.56-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Robin Lee 2012-05-27 05:27:36 EDT
Cannot reproduce.
Comment 3 David Kovalsky 2012-06-15 05:25:11 EDT
1) Edit any page
2) Copy text into clipboard just by selecting it
3) Click anywhere with the mouse wheen (paste)

booM!


Package: Zim-0.56-3.fc16
OS Release: Fedora release 16 (Verne)
Comment 4 David Kovalsky 2012-06-15 05:34:16 EDT
Hey Robin, I can reproduce this 100% given the steps above. 

Full reproducer is:
1) create new page
2) write 'reproducer'
3) use the mouse to select the word
4) press middle mouse button (wheel)

[Boom!]
Comment 5 Pierguido Lambri 2012-06-20 08:22:26 EDT
Editing a new page

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Milan Bartos 2012-09-10 04:56:09 EDT
Pasting code from firefox/github with middle mouse button.
But i'm not sure if this caused the problem.


Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Fedora Update System 2012-10-08 22:54:53 EDT
Zim-0.57-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Zim-0.57-1.fc16
Comment 8 ppecka 2012-10-09 18:57:29 EDT
i pasted notes object from libre office presentation into ZIM

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Fedora Update System 2012-10-09 20:30:41 EDT
Package Zim-0.57-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.57-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15741/Zim-0.57-1.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-11-19 00:35:50 EST
Zim-0.57-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Zim-0.57-2.fc16
Comment 11 Fedora Update System 2012-11-28 06:58:23 EST
Zim-0.57-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.