Bug 807176 - virt-top --help display should add parameter "netrx|nettx|blockrdrq|blockwrrq" for -o options
virt-top --help display should add parameter "netrx|nettx|blockrdrq|blockwrrq...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-top (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 04:32 EDT by Daisy Wu
Modified: 2013-02-21 05:07 EST (History)
6 users (show)

See Also:
Fixed In Version: virt-top-1.0.4-3.14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daisy Wu 2012-03-27 04:32:45 EDT
Description of problem:
virt-top --help display should add parameter "netrx|nettx|blockrdrq|blockwrrq" for -o options

Version-Release number of selected component (if applicable):
virt-top-1.0.4-3.13.el6.x86_64

# uname -a
Linux daisy.redhat.com 2.6.32-244.el6.x86_64 #1 SMP Tue Feb 28 12:58:47 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. #man virt-top
...
       -o sort
           Set the sort order to one of: cpu (sort by %CPU used), mem
           (sort by total memory), time (sort by total time), id (sort
           by domain ID), name (sort by domain name), netrx (sort by
           network received bytes), nettx (sort by network transmitted
           bytes), blockrdrq (sort by block device [disk] read
           requests), blockwrrq (sort by block device [disk] write
           requests).

           While virt-top is running you can change the sort order
           using keys P (cpu), M (memory), T (total time), N (domain
           ID), F (interactively select the sort field).

2. #virt-top --help
...
  -o sort           Set sort order (cpu|mem|time|id|name)


Actual resultes:
As above.

Expected results:
virt-top --help display should add "netrx|nettx|blockrdrq|blockwrrq" for -o options.
like:
  -o sort           Set sort order (cpu|mem|time|id|name|netrx|nettx|blockrdrq|blockwrrq)

Additional info:
Comment 2 Richard W.M. Jones 2012-03-27 12:49:14 EDT
Since this is a relatively minor bug, and the beta compose
is today, let's fix this for 6.4.
Comment 3 RHEL Product and Program Management 2012-07-10 01:51:33 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:58:31 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 yuping zhang 2012-09-29 01:57:24 EDT
Verified this issue with virt-top-1.0.4-3.14.el6.x86_64.

# virt-top --help
virt-top : a 'top'-like utility for virtualization

SUMMARY
  virt-top [-options]
....
 -o sort           Set sort order (cpu|mem|time|id|name|netrx|nettx|blockrdrq|blockwrrq)

...

And also test these options,they are works well.
So change the bug status to VERIFIED.
Comment 8 errata-xmlrpc 2013-02-21 05:07:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0391.html

Note You need to log in before you can comment on or make changes to this bug.