Bug 807188 - [abrt] inkscape-0.48.1-9.fc16: strncmp: Process /usr/bin/inkscape was killed by signal 11 (SIGSEGV)
[abrt] inkscape-0.48.1-9.fc16: strncmp: Process /usr/bin/inkscape was killed ...
Status: CLOSED DUPLICATE of bug 716325
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
abrt_hash:bbb049449bbcd28ceed2b2d5cd5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 05:00 EDT by cstent
Modified: 2012-03-30 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 09:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (34.10 KB, text/plain)
2012-03-27 05:00 EDT, cstent
no flags Details
File: dso_list (11.69 KB, text/plain)
2012-03-27 05:00 EDT, cstent
no flags Details
File: backtrace (98.34 KB, text/plain)
2012-03-27 05:01 EDT, cstent
no flags Details

  None (edit)
Description cstent 2012-03-27 05:00:51 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        inkscape
comment:        The crash happened while trying to save in Incskape svg format.
crash_function: strncmp
executable:     /usr/bin/inkscape
kernel:         3.3.0-4.fc16.i686
pid:            3014
pwd:            /home/cstent
reason:         Process /usr/bin/inkscape was killed by signal 11 (SIGSEGV)
time:           Tue 27 Mar 2012 11:05:06 AM EEST
uid:            1000
username:       cstent

backtrace:      Text file, 100696 bytes
dso_list:       Text file, 11967 bytes
maps:           Text file, 34921 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=PtolemaiosII.survey.ntua.gr
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=72edfb90d84d1ac0593f5dec0000001a-1332829345.592176-264998130
:GNOME_KEYRING_CONTROL=/tmp/keyring-VeTIAL
:IMSETTINGS_MODULE=none
:USER=cstent
:USERNAME=cstent
:MAIL=/var/spool/mail/cstent
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cstent/.local/bin:/home/cstent/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/cstent
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1644
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/cstent
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=cstent
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ph3kUgmDKk,guid=4e9375dd503ea1fc388311620000005c
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/cstent
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-cstent-gyD48C/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1652,unix/unix:/tmp/.ICE-unix/1652
:SSH_AUTH_SOCK=/tmp/keyring-VeTIAL/ssh
:GPG_AGENT_INFO=/tmp/keyring-VeTIAL/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-1882-PtolemaiosII.survey.ntua.gr-inkscape-1_TIME2396183
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-inkscape.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=3014

smolt_data:
:
:
:General
:=================================
:UUID: eb0c16d2-ede7-4c91-ad1a-f4ec6f4f2b6c
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 5999.95
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E6850  @ 3.00GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2999
:System Memory: 3030
:System Swap: 5087
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.0-4.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:955:4318:3157) pci, pcieport, PCI/PCI, C55 PCI Express bridge
:(4318:620:4163:33353) pci, snd_hda_intel, MULTIMEDIA, MCP51 High Definition Audio
:(4318:626:4163:33212) pci, None, RAM, MCP51 Memory Controller 0
:(4318:612:4163:33212) pci, nForce2_smbus, SERIAL, A8N-VM CSM Mainboard
:(4318:608:4163:33212) pci, None, PCI/ISA, A8N-VM CSM Mainboard
:(4318:931:0:0) pci, None, HOST/PCI, C55 Host Bridge
:(4318:937:0:0) pci, None, RAM, C55 Memory Controller
:(4318:938:0:0) pci, None, RAM, C55 Memory Controller
:(4318:947:0:0) pci, None, RAM, C55 Memory Controller
:(4318:946:0:0) pci, None, RAM, C55 Memory Controller
:(4318:945:0:0) pci, None, RAM, C55 Memory Controller
:(4318:944:0:0) pci, None, RAM, C55 Memory Controller
:(4318:943:0:0) pci, None, RAM, C55 Memory Controller
:(4318:942:0:0) pci, None, RAM, C55 Memory Controller
:(4318:941:0:0) pci, None, RAM, C55 Memory Controller
:(4318:940:0:0) pci, None, RAM, C55 Memory Controller
:(4318:949:0:0) pci, None, RAM, C55 Memory Controller
:(4318:948:0:0) pci, None, RAM, C55 Memory Controller
:(6523:9056:4163:33288) pci, ahci, STORAGE, JMB360 AHCI Controller
:(4318:939:0:0) pci, None, RAM, C55 Memory Controller
:(4318:617:4163:33313) pci, forcedeth, BRIDGE, MCP51 Ethernet Controller
:(4318:936:0:0) pci, None, RAM, C55 Memory Controller
:(4318:950:0:0) pci, None, RAM, C55 Memory Controller
:(4318:956:0:0) pci, None, RAM, C55 Memory Controller
:(4318:954:0:0) pci, None, RAM, C55 Memory Controller
:(4318:951:4318:3157) pci, pcieport, PCI/PCI, C55 PCI Express bridge
:(4318:623:4318:52100) pci, None, PCI/PCI, MCP51 PCI Bridge
:(4318:1057:0:0) pci, nouveau, VIDEO, G86 [GeForce 8500 GT]
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(4318:613:4163:33212) pci, pata_amd, STORAGE, A8N-VM CSM Mainboard
:(4318:624:4163:33212) pci, None, RAM, A8N-VM CSM Mainboard
:(4318:614:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:615:4163:33212) pci, sata_nv, STORAGE, A8N-VM CSM Mainboard
:(4318:621:4163:33212) pci, ohci_hcd, USB, A8N-VM CSM Mainboard
:(4318:622:4163:33212) pci, ehci_hcd, USB, A8N-VM CSM Mainboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ptolemaiosii-lv_root / ext4 4096 4096 13092026 9974140 9843108 3276800 2973903 2973903
:/dev/sda2 /boot ext4 1024 1024 508745 412294 386694 128016 127782 127782
:/dev/mapper/vg_ptolemaiosii-lv_home /home ext4 4096 4096 107435201 80549576 75171938 26894336 26832022 26832022
:

var_log_messages:
:Mar 26 18:56:11 PtolemaiosII kernel: [32217.584334] inkscape[9101]: segfault at 8 ip 4f3a9916 sp bfac7534 error 4 in libc-2.14.90.so[4f323000+1a7000]
:Mar 26 18:56:15 PtolemaiosII abrt[9110]: Saved core dump of pid 9101 (/usr/bin/inkscape) to /var/spool/abrt/ccpp-2012-03-26-18:56:11-9101 (101920768 bytes)
:Mar 27 11:05:06 PtolemaiosII kernel: [ 6252.734887] inkscape[3014]: segfault at 0 ip 4f46e724 sp bfab2d98 error 4 in libc-2.14.90.so[4f323000+1a7000]
:Mar 27 11:05:08 PtolemaiosII abrt[3963]: Saved core dump of pid 3014 (/usr/bin/inkscape) to /var/spool/abrt/ccpp-2012-03-27-11:05:06-3014 (129564672 bytes)

xsession_errors:
:(inkscape:3014): Gtk-WARNING **: Unable to retrieve the file info for `file:///home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Sobel_comparisons.pdf': Error stating file '/home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Sobel_comparisons.pdf': No such file or directory
:** (inkscape:3014): WARNING **: <image xlink:href="/home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_ADGradient_cross.png"> did not resolve to a valid image file (base dir is /home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/), now trying sodipodi:absref="/home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_ADGradient_cross.png"
:** (inkscape:3014): WARNING **: Unable to open linked file: /home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_ADGradient_cross.png
:** (inkscape:3014): WARNING **: <image xlink:href="/home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_Gradient_cross.png"> did not resolve to a valid image file (base dir is /home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/), now trying sodipodi:absref="/home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_Gradient_cross.png"
:** (inkscape:3014): WARNING **: Unable to open linked file: /home/cstent/Dropbox/2.Data_PhD/middlebury_stereo_pairs/tsukuba/results/CrossWindows/Gradient/DmapL_Gradient_cross.png
:(inkscape:3014): Gtk-WARNING **: Unable to retrieve the file info for `file:///home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Gradient_comparisons_2.svg': Error stating file '/home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Gradient_comparisons_2.svg': No such file or directory
:(inkscape:3014): Gtk-CRITICAL **: IA__gtk_tree_model_get: assertion `GTK_IS_TREE_MODEL (tree_model)' failed
:If you can reproduce this crash, please file a bug at www.inkscape.org
:(inkscape:3990): Gtk-WARNING **: Unable to retrieve the file info for `file:///home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Gradient_comparisons_2.pdf': Error stating file '/home/cstent/Dropbox/2.Data_PhD/results/CrossWindows/Gradient/results_matching_Gradient_comparisons_2.pdf': No such file or directory
:(inkscape:3990): Gtk-CRITICAL **: IA__gtk_widget_grab_default: assertion `gtk_widget_get_can_default (widget)' failed
Comment 1 cstent 2012-03-27 05:00:57 EDT
Created attachment 572982 [details]
File: maps
Comment 2 cstent 2012-03-27 05:00:59 EDT
Created attachment 572983 [details]
File: dso_list
Comment 3 cstent 2012-03-27 05:01:02 EDT
Created attachment 572984 [details]
File: backtrace
Comment 4 abrt-bot 2012-03-30 09:42:20 EDT
Backtrace analysis found this bug to be similar to bug #716325, closing as duplicate.

Bugs which were found to be similar to this bug: 
  gimp: bug #804338
  gtk2: bug #716325, bug #782487
  inkscape: bug #806973

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 716325 ***

Note You need to log in before you can comment on or make changes to this bug.