Bug 807220 - dd_rescue-1.27 is available
dd_rescue-1.27 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dd_rescue (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 06:13 EDT by Upstream Release Monitoring
Modified: 2013-02-02 08:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-02 08:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-03-27 06:13:29 EDT
Latest upstream release: 1.25
Current version in Fedora Rawhide: 1.23
URL: http://www.garloff.de/kurt/linux/ddrescue/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Account closed by user 2012-03-27 07:44:30 EDT
The current version is 1.25, released 2012-01-26.

Version 1.25 contains a fix for spurious "Success" messages that
resulted from overwritten (cleared) errno. Bad blocks are formatted in
a way that they are not overwritten on screen and block numbers are
output as unsigned.

Version 1.24 contains a compile fix for Linux versions that contain
the splice syscall but not the other definitions. I also allows for
specifying a directory (such as ".") as output filename in which case
dd_rescue just appends the input file basename to it, just like cp
does. Maybe most importantly, the RPM now contains the latest version
of dd_rhelp (0.1.2).
Comment 2 Account closed by user 2012-05-12 14:34:38 EDT
ping!
Comment 3 Michal Ambroz 2012-05-12 14:59:15 EDT
Hello guys,
please can you consider upgrading to the upstream stable version?
Or if you do not have time you can approve me as co-maintainer and I will do the update in the git.

http://rebus.fedorapeople.org/SPECS/dd_rescue.spec
http://rebus.fedorapeople.org/SRPMS/dd_rescue-1.25-1.fc17.src.rpm

Thank you
Michal Ambroz
Comment 4 Susi Lehtola 2012-05-12 20:23:05 EDT
The maintainer seems to be quite unresponsive. Please start

http://fedoraproject.org/wiki/Package_maintainer_policy#What_to_do_if_a_maintainer_is_absent
Comment 5 Upstream Release Monitoring 2012-05-18 06:09:10 EDT
Latest upstream release: 1.27
Current version in Fedora Rawhide: 1.23
URL: http://www.garloff.de/kurt/linux/ddrescue/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 6 Account closed by user 2012-05-18 12:51:58 EDT
The current version is 1.27, released 2012-05-17.

It allows to do 512b direct IO (which is possible in latest Linux
kernels) -- idea and patch from Jan Kara. Change posix_memalign()
variable assignment. It has a number of fixes from Valentin Lab;
most importantly, when exiting because of an error, it updates the
variables that are output. dd_rescue now avoid specal characters
in the logfile. It handles situations gracefully, where wrong
positions resulted in the progress graph causing faults. Some come
from illegal input (negative offset ...), which is nw detected.
Comment 7 Hans Ulrich Niedermann 2012-05-20 09:06:21 EDT
Apparently, dd_rescue-1.28 has been released as well.

I am currently building dd_rescue-1.28-1 (including dd_rhelp 0.3.0) for rawhide. F17 and F16 to follow.
Comment 8 Michal Ambroz 2012-05-20 09:12:32 EDT
Thank you Hans Ulrich
Comment 9 Fedora Update System 2012-05-20 09:36:52 EDT
dd_rescue-1.28-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dd_rescue-1.28-1.fc17
Comment 10 Fedora Update System 2012-05-20 09:37:02 EDT
dd_rescue-1.28-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dd_rescue-1.28-1.fc16
Comment 11 Fedora Update System 2012-05-20 14:35:10 EDT
Package dd_rescue-1.28-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dd_rescue-1.28-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8173/dd_rescue-1.28-1.fc17
then log in and leave karma (feedback).
Comment 12 Account closed by user 2012-05-20 17:52:13 EDT
maybe you also are interested in ddrescue, another flavor of the same tool. Also "orphan": https://bugzilla.redhat.com/show_bug.cgi?id=591042
Comment 13 Michal Ambroz 2012-07-29 07:43:12 EDT
Hello SCM team, 
Based on the approval from the FESco member Bill Nottingham 
http://lists.fedoraproject.org/pipermail/devel/2012-July/170318.html
please can you grant me rights to the dd_rescue to all branches be able to comaintain the package?

Package Change Request
======================
Package Name: dd_rescue
Owners: ixs jussilehtola rebus

Thank you
Michal Ambroz
Comment 14 Gwyn Ciesla 2012-07-29 14:14:29 EDT
Done.
Comment 15 Michal Ambroz 2012-08-02 18:36:04 EDT
Hello SCM team,
it seems based on the previous request I was granted the commit rights (thank you), but I didn't became second owner of the package. I probably was not clear enough in the request.

Please can you set me second owner of the package?

I already went through the procedure to take over the package.
http://fedoraproject.org/wiki/Package_maintainer_policy#What_to_do_if_a_maintainer_is_absent and it was approved by FESco member Bill Nottingham 
http://lists.fedoraproject.org/pipermail/devel/2012-July/170318.html

Best regards
Michal Ambroz
Comment 16 Gwyn Ciesla 2012-08-02 22:47:45 EDT
There isn't such a concept as second owner in pkgdb, simply owner and
comaintainers.
Comment 17 Michal Ambroz 2012-08-25 17:58:59 EDT
Hello,
I beg to differ - the SCM admin request guideline clearly states that there can be owners (more than one owner) of the package. Is the guideline wrong?

https://fedoraproject.org/wiki/Package_SCM_admin_requests

If there is no other option then I would like to become primary owner of the packages ddrescue and dd_rescue and ixs should be granted all rights to the package.

Best regards
Michal Ambroz
Comment 18 Gwyn Ciesla 2012-08-26 21:43:03 EDT
There is one primary owner, and comaintainers.  Operationally, there's no
real difference.  If you want to take ixs's place, you need to discuss it
with him, or being the unresponsive maintainer process.
Comment 19 Michal Ambroz 2012-08-27 10:41:27 EDT
Hello Jon,
>There is one primary owner, and co-maintainers.
If it is really like that, then I believe the "Package_SCM_admin_requests" guideline should be modified to reflect that, so we know what to ask for and what to expect. Please can you do that? 
So far the guideline is in all examples talking about "Owners:" (plural). 

>Operationally, there's no real difference.
Well - there is - I still do not have the grant ACL permission on the packages and I am not allowed to technically grant them to Jussi Lehota who asked to be comaintainer of the package.

>If you want to take ixs's place, you need to discuss it with him, 
>or being the unresponsive maintainer process.

Please let me recap this once again - this request is already result of "unresponsive maintainer process". 
Based on this service call (and similar service call to ddrescue) I have tried to contact ixs, asked on devel conference, and finally got approval from FESCO member Bill Nottingham to take over the package.
http://lists.fedoraproject.org/pipermail/devel/2012-July/170318.html

So please can you make me the owner of the package and make ixs co-maintainer?

Best regards
Michal Ambroz
Comment 20 Gwyn Ciesla 2012-08-27 10:50:18 EDT
Sorry, completely missed that part, I've orphaned both on all branches,
please take ownership.
Comment 21 Michal Ambroz 2013-02-02 08:41:49 EST
This bug obsoleted by 904733.
new version 1.30 already in rawhide and pending for updates for FC18

Note You need to log in before you can comment on or make changes to this bug.