Bug 807261 - gluster volume heal info without volume should display the usage message
Summary: gluster volume heal info without volume should display the usage message
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 11:46 UTC by M S Vishwanath Bhat
Modified: 2016-06-01 01:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-05 10:42:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description M S Vishwanath Bhat 2012-03-27 11:46:09 UTC
Description of problem:
gluster volume heal info (without volname) just says "operation failed". It should display the usage message

Version-Release number of selected component (if applicable):
git master

How reproducible:
Always

Steps to Reproduce:
1. Run gluster volume heal info
  
Actual results:
[root@QA-26 ~]# gluster v heal  info
operation failed
[root@QA-26 ~]# 

Expected results:
Should display the usage message or what is missing in the command

Comment 1 Anand Avati 2012-04-01 12:53:49 UTC
CHANGE: http://review.gluster.com/3057 (mgmt/glusterd: Improvements for volume heal CLI.) merged in master by Vijay Bellur (vijay@gluster.com)

Comment 2 M S Vishwanath Bhat 2012-04-05 10:42:01 UTC
Now it shows usage message when no volume is specified...


[root@QA-25 /]# gluster v heal info
Volume info does not exist


Note You need to log in before you can comment on or make changes to this bug.