Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 807300 - failed registration of a system with an activation key leaves client in unregistered state (though it is registered in katello)
Summary: failed registration of a system with an activation key leaves client in unreg...
Keywords:
Status: CLOSED DUPLICATE of bug 803814
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 13:11 UTC by Tom McKay
Modified: 2013-03-27 20:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-27 16:18:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tom McKay 2012-03-27 13:11:33 UTC
Description of problem:

When registering a system through an activation key (sub-mgr --activationkey=foo) that has a problem in it (eg. Pool with id ff80808 could not be found) leaves the system itself thinking it is not registered. Katello, however, lists the system as registered (though w/o any subscriptions, even the valid ones, in the activation key).

Further attempts to register the system will result in "Validation failed: Name has already been taken" errors from sub-mgr.

Comment 2 Lukas Zapletal 2012-03-27 15:44:17 UTC
Just a quick note - for activation keys there is a transaction implemented for subscriptions. If anything fails Katello tries to unsubscribe already subscribed entitlements. But activation is out of this transaction, so it does not get rolled out.

Comment 4 Tom McKay 2012-03-27 16:18:49 UTC

*** This bug has been marked as a duplicate of bug 803814 ***


Note You need to log in before you can comment on or make changes to this bug.