Bug 807306 - Seambay ftest fails with NotLoggedInException
Seambay ftest fails with NotLoggedInException
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.GA
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marek Novotny
Ondrej Skutka
Seam2.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 09:19 EDT by Ron Šmeral
Modified: 2016-10-31 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Seambay ftest fails with a NotLoggedInException because the SOAP message header is null when processing the message in the SOAPRequestHandler and the conversation ID not being set. This issue can be worked around by overriding org.jboss.seam.webservice.SOAPRequestHandler.handleOutbound. Procedure 2.1 details how to do this. 1. Create a file named SOAPRequestHandlerAS7.java and place it in SEAMBAY_EXAMPLE/src/org/jboss/seam/example/seambay with the following contents: <snipped code for brevity; it comes from the related JIRA> 2. Register the JAX-WS handler by: <snipped code for brevity; it comes from the related JIRA> 3. Reference the file from the web service implementation (AuctionService in this case) by annotating the class with @HandlerChain(file="../../../../../seam-jaxws-handlerchain.xml").
Story Points: ---
Clone Of:
Environment:
Fedora 16 64-bit, Mozilla Firefox 3.6.25, Oracle JDK 1.6.0_30, Seam 2.2.5.EAP5 (included in EAP 5.1.2.GA)
Last Closed: 2012-06-19 04:18:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (24.76 KB, text/plain)
2012-03-27 09:19 EDT, Ron Šmeral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-8376 Major Closed Seambay ftest fails with NotLoggedInException 2013-03-27 10:27:27 EDT

  None (edit)
Description Ron Šmeral 2012-03-27 09:19:57 EDT
Created attachment 573063 [details]
Server log

Seam version: 2.2.5.EAP5 (included in EAP 5.1.2.GA)
The seambay example from Seam 2.2 was migrated to EAP6 according to the migration guide on Documentation-Stage (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Beta_Documentation/Migrate_Seam_22_Archives_to_JBoss_Enterprise_Application_Platform_6.html)
and the bug was verified to occur with EAP 6.0.0.ER2.

Note: the seambay example ftests first fail due to this issue: https://issues.jboss.org/browse/JBPAPP-8322
After JBPAPP-8322 is patched, the following problem unfolds:

The createNewAuctionTest (or possibly some other, depending on execution order) fails with a NotLoggedInException.
It appears the main cause is the conversation ID not being propagated in SOAP requests by org.jboss.seam.webservice.SOAPRequestHandler.
There is a patch for this problem: https://gist.github.com/1996490

The ftest fails with:

[testng] FAILED: createNewAuctionTest
[testng] java.lang.AssertionError: Response area should contain information about creating the auction.

Relevant part of server log attached.
Comment 1 Ron Šmeral 2012-03-27 09:26:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The cause of this issue is the SOAP message header being null when processing the message in the SOAPRequestHandler and consequently, the conversation ID not being set.

This issue can be worked around by overriding org.jboss.seam.webservice.SOAPRequestHandler.handleOutbound, as described in https://issues.jboss.org/browse/JBPAPP-8376.
Comment 2 Rebecca Newton 2012-06-19 00:33:33 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1,13 @@
-The cause of this issue is the SOAP message header being null when processing the message in the SOAPRequestHandler and consequently, the conversation ID not being set.
+The Seambay ftest fails with a NotLoggedInException because the SOAP message header is null when processing the message in the SOAPRequestHandler and the conversation ID not being set.
 
-This issue can be worked around by overriding org.jboss.seam.webservice.SOAPRequestHandler.handleOutbound, as described in https://issues.jboss.org/browse/JBPAPP-8376.+This issue can be worked around by overriding org.jboss.seam.webservice.SOAPRequestHandler.handleOutbound. Procedure 2.1 details how to do this.
+
+1. Create a file named SOAPRequestHandlerAS7.java and place it in SEAMBAY_EXAMPLE/src/org/jboss/seam/example/seambay with the following contents:
+
+<snipped code for brevity; it comes from the related JIRA>
+
+2. Register the JAX-WS handler by:
+
+<snipped code for brevity; it comes from the related JIRA>
+
+3. Reference the file from the web service implementation (AuctionService in this case) by annotating the class with @HandlerChain(file="../../../../../seam-jaxws-handlerchain.xml").
Comment 4 Karel Piwko 2012-06-22 04:17:50 EDT
Seam 2.2 certification is a part of WFK 2.0.0.
Comment 6 JBoss JIRA Server 2012-07-17 16:39:43 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8376 to Resolved
Comment 7 JBoss JIRA Server 2012-08-26 20:17:59 EDT
Rajesh Rajasekaran <rajesh.rajasekaran@jboss.com> updated the status of jira JBPAPP-8376 to Closed
Comment 8 JBoss JIRA Server 2012-08-26 20:17:59 EDT
Rajesh Rajasekaran <rajesh.rajasekaran@jboss.com> made a comment on jira JBPAPP-8376

Marking "Won't fix", "Rejected" and "Out of Date" items as CLOSED.
Comment 9 JBoss JIRA Server 2012-10-02 04:18:30 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8376 to Reopened
Comment 10 JBoss JIRA Server 2012-10-02 04:18:30 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBPAPP-8376

Reopening because this seems like an issue in implementation of SOAPRequestHandler.

SOAPHeader is used by Seam for storing conversation ID and it is IMO wrongly ignored when SOAPHeader is not in SOAP message.
Comment 11 JBoss JIRA Server 2012-10-02 04:48:55 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8376 to Resolved
Comment 14 JBoss JIRA Server 2012-11-13 09:46:04 EST
Marek Schmidt <maschmid@redhat.com> updated the status of jira JBPAPP-8376 to Closed
Comment 15 JBoss JIRA Server 2012-11-13 09:46:04 EST
Marek Schmidt <maschmid@redhat.com> made a comment on jira JBPAPP-8376

Verified with Seam from EAP 5.2.0.ER4 on EAP 6.0.1 ER3

Note You need to log in before you can comment on or make changes to this bug.