Bug 807308 - printing 2 pages per sheet in portrait mode cuts off text on the right side
Summary: printing 2 pages per sheet in portrait mode cuts off text on the right side
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 13:22 UTC by Martin Jürgens
Modified: 2013-02-13 23:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 23:52:36 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Jürgens 2012-03-27 13:22:30 UTC
Description of problem:
I have a Samsung ML-2010 printer with the Samsung ML-2010 Foomatic/gdi driver.

When I have a document with two pages and use the "pages per sheet" option (set to 2) in the printing dialog, the result is "garbage" (see actual results).

Version-Release number of selected component (if applicable):
libreoffice-writer-3.4.5.2-8.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a document full of text with two pages in libre office
2. select print -> page layout -> pages per sheet "2"
3. press print
  
Actual results:
printed page still is in upright format, and only one and a half page is printed onto it (side by side), the other half is missing.

Expected results:
both pages on sheet in landscape format, as it used to be.

Additional info:
when I export the document as a PDF-file, and print it using evince ("pages per sheet 2"), it works just fine.

Comment 1 David Tardon 2012-03-28 09:42:19 UTC
3.4 does not automatically switch to landscape mode--you have to do it yourself in printer properties. This is fixed in 3.5 . But it prints fine here even in portrait mode. How does the page look in preview?

Comment 2 Martin Jürgens 2012-04-01 22:33:39 UTC
the preview is fine (nothing cut off)

Comment 3 Caolan McNamara 2012-04-02 10:18:01 UTC
might be cups, what sort of printer is it ? An HP ?

Comment 4 Martin Jürgens 2012-04-02 10:34:42 UTC
Samsung ML-2010.

The two pages per sheet option works fine with Envince.

Comment 5 Martin Jürgens 2012-04-02 10:50:37 UTC
What I've now tried is that I installed cups-pdf and printed the page via CupsPDF. The result is just fine then.
I've also readded my Samsung printer, which did not solve the issue.

some information about my printer:
Beschreibung:	Samsung ML-2010
Ort:	
Treiber:	Samsung ML-2010 Foomatic/gdi (grayscale, 2-sided printing)
Verbindung:	socket://192.168.178.200:9100
Einstellungen:	job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

Comment 6 Caolan McNamara 2012-04-10 12:37:09 UTC
If it worked via one printing backend and not via some other, I'd guess the problem might be in some part of the cups constellation of stuff somewhere.

Comment 7 Jiri Popelka 2012-04-10 15:17:02 UTC
(In reply to comment #4)
> Samsung ML-2010.

There's also a driver in splix package. Please install splix package and change (you can use system-config-printer) the driver to "Samsung ML-2010, 2.0.0".

Can you also show me what does the following command show:
/usr/lib/cups/backend/snmp 192.168.178.200

(In reply to comment #5)
> What I've now tried is that I installed cups-pdf and printed the page via
> CupsPDF. The result is just fine then.

To summarize this:
If the document is exported or printed to PDF first, then printing ("pages per sheet 2") this PDF is OK.
Printing ("pages per sheet 2") the document directly from libre office is not OK.
Is that correct ?

Comment 8 Martin Jürgens 2012-04-10 15:30:41 UTC
there are three different scenarios:
a) I export the document as a PDF from within LibreOffice (just pressing Export PDF button, without having set the pages per sheet option), open it with Envince, choose "pages per
sheet 2" in the printing dialog of Envince and print it. Result: Everything fine
b) I install cups-pdf (a PDF printer that appears in the printing dialog) and print the document from within LibreOffice (having set "pages per
sheet 2"). Result: Everything fine
*c*) I print it from within LibreOffice to my Samsung ML-2010 (having set "pages per
sheet 2"). Result: "cut off"

Will run that command as soon as I have access to the machine again, which may take one week.

Comment 9 Martin Jürgens 2012-04-15 15:08:02 UTC
[root@kedora ~]# /usr/lib/cups/backend/snmp 192.168.178.200
[root@kedora ~]#

Comment 10 Martin Jürgens 2012-04-15 15:12:37 UTC
works fine with splix

Comment 11 Jiri Popelka 2012-04-18 14:22:37 UTC
So that seems to be a problem with the Foomatic/gdi driver, moving this BZ to foomatic.

Comment 16 Fedora End Of Life 2013-01-16 20:28:40 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 17 Fedora End Of Life 2013-02-13 23:52:40 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.