Bug 807333 - Signed cglib.jar prevents seam2 spring ftest from working
Signed cglib.jar prevents seam2 spring ftest from working
Status: CLOSED CANTFIX
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.GA
Unspecified Unspecified
medium Severity urgent
: ---
: ---
Assigned To: Marek Novotny
Seam2.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 10:36 EDT by Ron Šmeral
Modified: 2016-10-31 21:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This issue can be worked around by unsigning the cglib.jar as in: zip -d $SEAM_DIR/lib/cglib.jar META-INF/JBOSSCOD\*
Story Points: ---
Clone Of:
Environment:
Fedora 16 64-bit, Mozilla Firefox 3.6.25, Oracle JDK 1.6.0_30, Seam 2.2.5.EAP5 (included in EAP 5.1.2.GA)
Last Closed: 2012-06-18 11:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (15.62 KB, text/plain)
2012-03-27 10:36 EDT, Ron Šmeral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-8465 Critical Closed Signed cglib.jar prevents seam2 spring ftest from working 2014-07-30 06:50:33 EDT

  None (edit)
Description Ron Šmeral 2012-03-27 10:36:46 EDT
Created attachment 573084 [details]
Server log

Seam version: 2.2.5.EAP5 (included in EAP 5.1.2.GA)
The spring example from Seam 2.2 was migrated to EAP6 according to the migration guide on Documentation-Stage (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6/html/Beta_Documentation/Migrate_Seam_22_Archives_to_JBoss_Enterprise_Application_Platform_6.html)
and the bug was verified to occur with EAP 6.0.0.ER3.

When the ftests are run, they fail immediately.

Relevant part of server log attached.
Comment 1 Ron Šmeral 2012-03-27 10:48:21 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This issue can be worked around by unsigning the cglib.jar as in:
zip -d $SEAM_DIR/lib/cglib.jar META-INF/JBOSSCOD\*
Comment 3 sgilda 2012-05-26 08:52:24 EDT
Never mind. I misunderstood. I think I understand what you're saying here.
Comment 4 Marek Novotny 2012-05-28 03:31:58 EDT
That issue should disappear in EAP 6 GA as we will distribute unsigned jars.
Comment 5 Marek Schmidt 2012-05-28 03:50:30 EDT
I have tested it with EAP6.0.0.ER8, which is *not* signed and the error is still the same, so apparently the signed cglib from Seam2.2.5.EAP5 doesn't work even on the unsigned EAP6.
Comment 6 Karel Piwko 2012-06-04 07:05:13 EDT
Marek Schmidt, the problem is being the signed cglib not the signed EAP6.
Comment 8 JBoss JIRA Server 2012-06-04 08:34:16 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBPAPP-8465

Bundle cglib.jar from jboss-as/common/lib/cglib.jar or edit jboss-as/bin/security_cc.policy and add something like 

{noformat}
grant codeBase "file:${jboss.home.dir}/common/lib/cglib.jar" {
   permission java.security.AllPermission;
};
{noformat}
Comment 10 mark yarborough 2012-06-18 11:32:15 EDT
WFK 2.0 does not delivere Seam 2.2, however, these issues have already been documented in the EAP 6 release notes, so no need to duplicate each issue in WFk 2.0 release notes. However, we should include a pointer to the EAP 6 release notes to assist customers looking for Seam 2.2 bug information.
Comment 11 JBoss JIRA Server 2012-07-20 08:12:09 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBPAPP-8465 to Resolved
Comment 12 JBoss JIRA Server 2012-07-20 08:12:09 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBPAPP-8465

I have removed cglib from spring and jee5/booking examples. They can use cglib and asm from EAP AS libraries. cglib is now required only for seam-gen and reverse db generation.
Comment 13 JBoss JIRA Server 2012-09-07 11:07:00 EDT
Ron Šmeral <rsmeral@redhat.com> updated the status of jira JBPAPP-8465 to Reopened
Comment 14 JBoss JIRA Server 2012-09-07 11:07:00 EDT
Ron Šmeral <rsmeral@redhat.com> made a comment on jira JBPAPP-8465

It appears to be still broken, the CGLIB is not found on the classpath:
{noformat}
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'userService' defined in ServletContext resource [/WEB-INF/applicationContext.xml]: Initialization of bean failed; nested exception is org.springframework.aop.framework.AopConfigException: Cannot proxy target class because CGLIB2 is not available. Add CGLIB to the class path or specify proxy interfaces.
{noformat}
Comment 15 JBoss JIRA Server 2012-09-10 09:31:24 EDT
Ron Šmeral <rsmeral@redhat.com> made a comment on jira JBPAPP-8465

I haven't read the previous comment properly. After including {{jboss-as/common/lib/cglib.jar}} in the classpath, the test passes.
Comment 16 JBoss JIRA Server 2012-09-10 09:34:18 EDT
Ron Šmeral <rsmeral@redhat.com> updated the status of jira JBPAPP-8465 to Closed
Comment 17 JBoss JIRA Server 2012-10-29 21:05:02 EDT
Russell Dickenson <rdickens@redhat.com> updated the status of jira JBPAPP-8465 to Reopened
Comment 18 JBoss JIRA Server 2012-10-29 21:05:02 EDT
Russell Dickenson <rdickens@redhat.com> made a comment on jira JBPAPP-8465

Issue reopened to change Release Notes field.
Comment 19 JBoss JIRA Server 2012-10-29 21:07:12 EDT
Russell Dickenson <rdickens@redhat.com> updated the status of jira JBPAPP-8465 to Closed

Note You need to log in before you can comment on or make changes to this bug.