Bug 807359 - Cannot import repo content from XML due to VersionException. ModeShape used.
Cannot import repo content from XML due to VersionException. ModeShape used.
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Modeshape (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: BRMS 5.3.0.GA
Assigned To: Horia Chiorean
Petr Široký
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 11:27 EDT by Petr Široký
Modified: 2013-10-24 05:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
serve log file (152.73 KB, application/octet-stream)
2012-03-28 04:37 EDT, Petr Široký
no flags Details
XML repo export (8.35 KB, text/xml)
2012-03-28 04:38 EDT, Petr Široký
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-1450 Major Closed Importing a Guvnor system view XML file fails 2013-10-24 05:50:55 EDT

  None (edit)
Description Petr Široký 2012-03-27 11:27:23 EDT
Description of problem:
When trying to import repository content from XML into Guvnor, the following exception is thrown.

javax.jcr.version.VersionException: Cannot add the child node named 'assets' under '/drools:repository/drools:package_area/defaultPackage' because it is checked in and the child's node definition '*' has an on-parent-version attribute of 'COPY' (must be 'ignore' to add child to checked-in parent)


Steps to Reproduce:
1. Download and start Guvnor bundled with BRMS 5.3 ER5.
2. Setup ModeShape as JCR repository.
3. Import the attached xml file into Guvnor.
  
Actual results:
The above exception is thrown.

Expected results:
The content is successfully imported.

Additional info:
ModeShape version used is 2.8.1.GA. Note that this was _not_ happening with 2.5.x.
Comment 2 Van Halbert 2012-03-27 11:40:43 EDT
Can you attach the XML file that was imported?
Comment 4 Horia Chiorean 2012-03-28 03:18:16 EDT
Also, please attach the server log which contains the exception.
Comment 5 Petr Široký 2012-03-28 04:37:10 EDT
Created attachment 573268 [details]
serve log file
Comment 6 Petr Široký 2012-03-28 04:38:08 EDT
Created attachment 573269 [details]
XML repo export
Comment 7 Petr Široký 2012-03-28 04:39:39 EDT
Sorry, guys. I thought I attached both server.log and XML file when creating the issue, but somehow it wasn't there. It's fixed now.
Comment 8 JBoss JIRA Server 2012-03-30 07:36:39 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1450

Issue was caused by the fact that imported nodes were considered checked-in. 

The fix was to disable the check-in behaviour when importing content from XML.

The fix can be cherry-picked into the 2.x branch as well
Comment 9 JBoss JIRA Server 2012-03-30 09:04:41 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-1450

Merged into the '2.8.x' branch and cherry-picked into the '2.x' branch.
Comment 10 Petr Široký 2012-03-30 09:07:11 EDT
Thanks for fixing it so quick! I will verify that when new build arrives.
Comment 11 Ryan Zhang 2012-04-23 03:38:29 EDT
Update status to ON_QA. Please verify them against ER6.
Comment 12 Petr Široký 2012-04-25 04:59:46 EDT
Verified fixed in 5.3.0 ER6.
Comment 16 JBoss JIRA Server 2013-10-24 05:22:02 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-1450 to Closed

Note You need to log in before you can comment on or make changes to this bug.