Bug 807397 - updates.img images do not work on live installs since the new format
updates.img images do not work on live installs since the new format
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-27 12:52 EDT by Adam Williamson
Modified: 2012-03-29 00:12 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-17.16-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 00:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-03-27 12:52:23 EDT
It seems in anaconda 17, updates.img may now contain an entire anaconda tree in subdirectories of /tmp/updates . prior to 17, they just contained a pyanaconda directory at the top level.

dracut has been adjusted for the new format, so updates work on non-live installs (allegedly), but liveinst hasn't, so when you use an updates.img for a live install, you get a /tmp/updates/tmp/updates/ folder with all the changed data below that, and it never gets read because of the extra layers.

The fix for this is to adjust the updates.img loading code in liveinst (after the comment "# We officially support two updates.img formats:  a filesystem image, and a compressed cpio blob.") to not change directory to /tmp/updates before extracting cpio blob-format updates.img files, and to mount filesystem image-format updates.img files in a temporary location then copy them appropriately into /tmp/updates (because we can't very well mount them at /).

Nominating as a Beta blocker per Alpha criterion "The installer must be able to download and use an installer update image from an HTTP server", in the case of live installation.
Comment 1 Fedora Update System 2012-03-28 19:22:25 EDT
anaconda-17.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.16-1.fc17
Comment 2 Adam Williamson 2012-03-28 20:08:03 EDT
Discussed at 2012-03-28 go/no-go meeting, acting as a blocker review meeting. Accepted as a blocker per criterion "The installer must be able to download and use an installer update image from an HTTP server".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2012-03-29 00:08:17 EDT
Fix confirmed in RC2. beefiness is present.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Fedora Update System 2012-03-29 00:12:52 EDT
anaconda-17.16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.