Bug 807401 - xen kernel crashes when using encrypted filesystem
xen kernel crashes when using encrypted filesystem
Status: CLOSED DUPLICATE of bug 804347
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
16
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:06 EDT by Gerry Reno
Modified: 2012-03-31 16:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 14:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2012-03-27 13:06:13 EDT
Description of problem:
I installed F16 on an encrypted filesystem.  Baremetal kernel boots fine (3.2.10 and 3.3.0).  However, when I try to boot any of the Xen entries (4.1, 4.1.2) the kernel panics immediately on start of boot.  No prompt is given to enter encrypted filesystem password.  

Version-Release number of selected component (if applicable):
kernel 3.2.10
kernel 3.3.0

How reproducible:
Always

Steps to Reproduce:
1. install F16 on encrypted filesystem
2. install Xen
3. try to boot any Xen boot entry
  
Actual results:
kernel panics

Expected results:
receive prompt for encrypted filesystem password and system then boots Xen kernel.

Additional info:
Comment 1 Konrad Rzeszutek Wilk 2012-03-27 13:54:02 EDT
Is this a dup of 804347 ?
Comment 2 Gerry Reno 2012-03-27 14:02:32 EDT
Konrad, That bug seems related to APIC.

When I boot both 3.2.10 and 3.3.0 without Xen they boot fine so I don't think this bug is the same problem.

.
Comment 3 Gerry Reno 2012-03-27 14:18:26 EDT
Konrad, I just looked again at the kernel panic screen and it is nearly the same as the one in bug 804347 so this may indeed be the same issue.

Marking as dup of 804347.

*** This bug has been marked as a duplicate of bug 804347 ***
Comment 4 Gerry Reno 2012-03-31 16:19:00 EDT
I tested with kernal-PAE-3.3.0-8 and the kernel panic is now gone but all is still not well with xen kernel bootup.  I'll open another bug on what I see now.

Note You need to log in before you can comment on or make changes to this bug.