Bug 807413 - [PATCH] switch default display device to QXL
[PATCH] switch default display device to QXL
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:43 EDT by Bill Nottingham
Modified: 2014-03-16 23:30 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 10:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-03-27 13:43:05 EDT
Description of problem:

Because cirrus causes kittens to kill kittens in a horrible kitten-killing arena.
(Others can elucidate on cirrus' lameness if so desired.)

Version-Release number of selected component (if applicable):

qemu-1.0-6.fc17

How reproducible:

100%

Steps to Reproduce:
1. Look at qemu defaults
2. See 'cirrus'
  
Actual results:

Dead kittens.

Expected results:

Spice.

Additional info:

diff -up qemu-kvm-1.0/vl.c.foo qemu-kvm-1.0/vl.c
--- qemu-kvm-1.0/vl.c.foo	2012-03-27 13:38:39.721397415 -0400
+++ qemu-kvm-1.0/vl.c	2012-03-27 13:38:57.708397915 -0400
@@ -3221,7 +3221,7 @@ int main(int argc, char **argv, char **e
             add_device_config(DEV_VIRTCON, "vc:80Cx24C");
     }
     if (default_vga)
-        vga_interface_type = VGA_CIRRUS;
+        vga_interface_type = VGA_QXL;
 
     socket_init();
Comment 1 Daniel Berrange 2012-03-27 14:01:23 EDT
I don't think we can do this because some OS (eg Fedora 16) have QXL drivers which are pretty fubar and thus should not be used.

We could at least switch to the STDVGA driver though, which should be an improvement.

Any use of QXL should be controlled by libosinfo (or equivalent per-OS config databases in virt-install, etc)
Comment 2 Bill Nottingham 2012-03-27 14:09:07 EDT
OSes can fall back to vesa (and ours should be fixed).
Comment 3 Daniel Berrange 2012-03-27 14:41:41 EDT
We can't retroactively fix existing released media. This kind of issue is exactly why we maintain databases of per-OS default hardware drivers.
Comment 4 Cole Robinson 2012-04-24 10:49:30 EDT
Yeah, closing this WONTFIX. Changing the default at the qemu level just isn't an option unless the change was upstream first (and it's highly unlikely upstream would make this change).

As danpb mentions, the way forward with this is getting VM building tools to use libosinfo.

Note You need to log in before you can comment on or make changes to this bug.