This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 807416 - SystemManager.getServerVersion(subject) method is not in the API
SystemManager.getServerVersion(subject) method is not in the API
Status: CLOSED DUPLICATE of bug 807393
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:58 EDT by Mike Foley
Modified: 2012-04-02 11:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 11:51:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemmanager.js (878 bytes, application/javascript)
2012-03-27 13:58 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2012-03-27 13:58:14 EDT
Created attachment 573146 [details]
systemmanager.js

Description of problem:  SystemManager.getServerVersion(subject) method is not in the API


Version-Release number of selected component (if applicable):  JON 3.1


How reproducible: 100%


Steps to Reproduce:
1.  use the remote CLI ... as follows:
./rhq-cli.sh -u rhqadmin -p rhqadmin -f /home/mfoley/automation2/automatjon/jon/clitest/resources/js-files/systemmanager.js 

(this file is attached)


  
Actual results:

mfoley@foleymonsterbox1 bin]$ ./rhq-cli.sh -u rhqadmin -p rhqadmin -f /home/mfoley/automation2/automatjon/jon/clitest/resources/js-files/systemmanager.js 
Remote server version is: 4.4.0-SNAPSHOT (94f6790)
Login successful
Exception in thread "main" org.rhq.enterprise.client.script.CLIScriptException: javax.script.ScriptException: sun.org.mozilla.javascript.EcmaError: TypeError: Cannot find function getServerVersion in object SystemManagerBean. (<Unknown source>#10) in <Unknown source> at line number 10



Expected results:

the method should exist ... for 2 reasons:
1) it is documented in the CLI API doc
2) it was in a developer-written CLI test at this location 
http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=blob_plain;f=modules/cli-tests/src/test/script/org/rhq/enterprise/remoting/cli/test_SystemManager.js;h=4316690446e33b4d433d7b07eb1a5ce7e83fcc8e;hb=HEAD

Additional info:  attachments
Comment 1 Mike Foley 2012-03-27 14:48:13 EDT
API changed unexpectedly ... 

* ccrouch-grabfood is now known as ccrouch
<jshaughn> ok, it was unceremoniously changed 2/9/11.  It was not deprecated. Just manhandled.
Comment 2 Mike Foley 2012-03-27 14:51:08 EDT
link to API doc is not correct for master

<jshaughn> the doc does match the API, that was the API for that version. It is *not* the right link for master.
Comment 3 Mike Foley 2012-03-27 15:17:21 EDT
<jshaughn> sunny-dee: I thought so
<sunny-dee> i can get with ips about what to do for wiki publishing
<jshaughn> Our RHQ release process should be updated to include this in the RHQ wiki
<jshaughn> which, as mfolye just pointed out, is sadly out of date
<jshaughn> I'm not sure how easy it is for us to actually add the requisite pages to the wiki
<sunny-dee> i think the rhq wiki even points to, like, the jon 2.3 api docs
Comment 4 Mike Foley 2012-04-02 11:41:59 EDT
documented and x-ref'd in https://bugzilla.redhat.com/show_bug.cgi?id=803737
Comment 5 Mike Foley 2012-04-02 11:51:57 EDT
the resolution of this BZ 807393

*** This bug has been marked as a duplicate of bug 807393 ***

Note You need to log in before you can comment on or make changes to this bug.