Bug 80743 - Keyboard Shortcuts: default key bindings for Move window to workspace # don't work
Keyboard Shortcuts: default key bindings for Move window to workspace # don't...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: MoveUpstream, Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-30 13:52 EST by Alexandre Oliva
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-11 23:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-12-30 13:52:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
The default keybindings (from a home directory created with 8.0, in case it
matters) for `Move window to workspace [1234]' are <Control> <Alt>
{exclam,at,numbersign,dollar}.  These imply shift is depressed, and it causes
the key sequences not to work.  If I click on the shortcut and redefine it by
pressing the appropriate sequences, I get <Shift> <Control> <Alt>
{exclam,at,numbersign,dollar}, and from this point on, the shortcut works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try Ctrl-Alt-Shift-2,
2.Change the key binding to what the one you'd expect to work
3.Get <Shift> prepended to the sequence
4.Try it again

Actual Results:  1. fails, 4. works.

Expected Results:  Either the default should be changed to something that works,
or whatever interprets the sequence should be made smarter such that the current
default (that looks saner) works.

Additional info:
Comment 1 Havoc Pennington 2003-01-02 16:40:43 EST
Hmm, strange. I'll look at it in metacity CVS and just let it trickle 
down to Red Hat eventually.
Comment 2 Jonathan Blandford 2003-01-15 15:14:52 EST
Looks like a bug in eggcellrendererkeys.  It's now recording <shift>exclam
instead of <shift>1.  Changing the key in gconf-editor gives the proper result.
 I'll see if I can figure out what changed to cause this.
Comment 3 Jonathan Blandford 2003-01-15 16:54:28 EST
This was broken in 8.0 and no one noticed.  There are two bugs here.

1) Metacity needs to check the keycode of it's events instead of the keysym.
2) The egg* code needs to try to store a more 'human understandable' key. 
Second part is filed upstream as:

http://bugzilla.gnome.org/show_bug.cgi?id=103603

Moving this bug to metacity.
Comment 4 Alexandre Oliva 2003-01-23 10:20:15 EST
It appears that the defaults are gone from phoebe2, which at least hides the
problem.  However, setting the key sequences to say Ctrl-Alt-Shift-2 in keyboard
shortcuts prefs gets us <Shift><Ctrl><Alt>at, and the shortcut doesn't work at
all.  One has to go to gconftool and change the at to 2 for it to work.
Comment 5 Alexandre Oliva 2003-05-11 20:25:30 EDT
I see that, in Shrike, the shortcut works regardless of whether it says `2' or
`at'.  You still get `at' if you enter the shortcut in the keyboard, though,
which is reasonable.  If you really mean Shift 2 (in case at is not Shift 2),
you can still set it with gconf-editor, so I guess we're ok.

Note You need to log in before you can comment on or make changes to this bug.