Bug 8075 - DHCP config problems with pump on ppp+eth0 machine
DHCP config problems with pump on ppp+eth0 machine
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-30 18:06 EST by Brian Chronowski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 19:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Chronowski 1999-12-30 18:06:49 EST
On a system with both a modem and network card configured by dhcp:

Normally you set your DNS settings in "netconf", however, in a system with
both a modem and a Network Interface Card configured by DHCP, your DNS
settings will be overwritten on each boot with the alleged "gateway"
address, whether or not it provides accurate DNS service. (Ours certainly
doesn't =) If you fiddle with the settings enough (ie, removing the default
domain, or changing the priority of DNS on the same screen) your system
will never, ever boot again. (Hangs at 'initializing eth0', in my test, for
well over a day before I rebooted it.) I don't know which actual service is
causing the problem, though obviously it's something to do with the nic
routines or dhcp configuration utility. To avoid hearing "update the
driver", or something equally inspired, I should mention that we have
tested this on multiple computers, nics, and modems, and have found the
problem universal. It is also worth note that, upon installing 6.0 on those
computers, there is no longer any problem. As our distributor can no longer
acquire RedHat 6.0 retail, this is not a viable option for customers who
want the full documentation with the product.  This seems to be a high
priority item, as a lot of systems do go out the door with both devices...

P.S. While normally I'd like to just submit a bug report, instead of
blaming it on a specific component, (and then being wrong), bugzilla
doesn't seem much inclined to allow me to do so. So if pump isn't at fault,
I have no idea what is.
Comment 1 Elliot Lee 2001-07-16 19:24:36 EDT
This seems to be a very special case that may just require a manual hack on the
sysadmin's part. If I gather correctly, the problem is that dhcpd is writing the
resolv.conf twice and the final result is the one from the modem rather than
eth0? It is somewhat confusing because you refer to both DNS (name resolution
settings) and the gateway (routing settings).

(I've never seen DHCP over a serial modem - PPP has its own settings negotiation
protocol.)
Comment 2 Elliot Lee 2001-07-30 15:46:12 EDT
No reply, not a surprise after all this time.

Note You need to log in before you can comment on or make changes to this bug.