Bug 80750 - matroxfb does not work with vesafb compiled-in
matroxfb does not work with vesafb compiled-in
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-30 16:40 EST by Sami Knuutinen
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Knuutinen 2002-12-30 16:40:50 EST
Description of problem:
The matroxfb is compiled as a module in kernel-2.4.18-19.8.0 and the
documentation (/usr/src/linux/Documentation/fb/matroxfb.txt) tells you can use
it by passing, for example, the command line "video=matrox:vesa:0x1BB" to the
kernel. This didn't work and then I noticed that the documentation also says:
"You should not compile-in vesafb unless you have primary display on non-Matrox
VBE2.0 device". The vesafb is compiled in the kernel-2.4.18-19.8.0 and I think
this is why the matroxfb doesn't work. I haven't yet tried recompiling the
kernel without the vesafb compiled-in, but I think that it works ok without the
vesafb.

Is there a way to get matroxfb working without recompiling the kernel?

Version-Release number of selected component (if applicable):
kernel-2.4.18-19.8.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Alan Cox 2003-06-05 09:38:34 EDT
We boot with vesafb present but not in use by default. This will not interfere
with matroxfb,
you do need to load the matroxfb modules to use it however. Matroxfb is
something we ship because it seems to work rather than because its likely to be
useful. The X server does not need matroxfb to be present


Note You need to log in before you can comment on or make changes to this bug.