Bug 807510 - Fail to boot after installation via EFI on system without KMS graphics support
Fail to boot after installation via EFI on system without KMS graphics support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
Depends On:
Blocks: F17Beta-accepted/F17BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-03-27 22:36 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-17.20-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 13:22:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf (757 bytes, text/plain)
2012-03-27 23:32 EDT, Xiaowei Li
no flags Details
disk information (788 bytes, text/plain)
2012-03-27 23:35 EDT, Xiaowei Li
no flags Details
grub.conf generated by anaconda during F17 beta RC2 EFI install (772 bytes, text/plain)
2012-04-02 13:01 EDT, Tim Flink
no flags Details
anaconda program.log from F17 beta RC2 EFI install (239.57 KB, text/plain)
2012-04-02 13:02 EDT, Tim Flink
no flags Details
anaconda log from F17 beta RC2 EFI install (21.75 KB, text/plain)
2012-04-02 13:35 EDT, Tim Flink
no flags Details
anaconda storage.log from F17 beta RC2 EFI install (235.25 KB, text/plain)
2012-04-02 13:36 EDT, Tim Flink
no flags Details
syslog from F17 beta RC2 EFI install (162.34 KB, text/plain)
2012-04-02 13:36 EDT, Tim Flink
no flags Details
yum log from F17 beta RC2 EFI install (153.37 KB, text/plain)
2012-04-02 14:08 EDT, Tim Flink
no flags Details
anaconda.tar (passed with F17RC3) (680.00 KB, application/x-tar)
2012-04-06 03:06 EDT, Xiaowei Li
no flags Details

  None (edit)
Description Xiaowei Li 2012-03-27 22:36:27 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always.
I can install the RHEL 6U2 workstation(minimal package) on the box. So it should not be the hardware issue.

Steps to Reproduce:
1. install F17RC on the IBM x3500M3 ( ServerRAID based on LSI megaRAID, boot device is RAID0 with 1 SAS disk )
2. select 'Specialized Storage Devices' and anaconda can display the 'ServerRAID‘ device in the basic device tab page. 
3. process 'Next' and select all the default configuration to install the F17(minimal pacakge)
4. reboot the system after installation completion.
  
Actual results:

The system throws the following message and hung after executing grub.
Trying to allocate 1135 page for VMLINUZ 
Got page at Ox7971d000
[Linux-EFI, setup=0x10c4, size=0x46e050]
    [Initrd, addr=0x78923000, size=0xdf93c2]


Expected results:


Additional info:
Comment 1 Xiaowei Li 2012-03-27 22:45:09 EDT
Disk device mode - IBM ServerRAID M1015
Comment 2 Xiaowei Li 2012-03-27 23:32:02 EDT
Created attachment 573214 [details]
grub.conf
Comment 3 Xiaowei Li 2012-03-27 23:35:14 EDT
Created attachment 573215 [details]
disk information
Comment 4 Xiaowei Li 2012-03-27 23:38:45 EDT
another issue, i used the DVD image to boot into rescue mode but failed to mount the disk automatically and no lvm devices found in /dev/mapper.

I can mount the EFI boot and boot partition manually. if you need the information in the root volume please let me know.
Comment 5 Hongqing Yang 2012-03-31 04:55:12 EDT
This should be Beta Blocker according article:
8.The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot
Comment 6 Hongqing Yang 2012-03-31 04:55:59 EDT
This should be a Beta Blocker according article:
8.The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot
Comment 7 Adam Williamson 2012-03-31 12:27:57 EDT
Please re-test with RC2, thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2012-04-02 11:30:38 EDT
also, when you re-test, can you try not going into 'advanced storage devices'? that doesn't seem like it ought to be necessary (though really it shouldn't break anything).

please re-test this soon, we need the data! Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Peter Jones 2012-04-02 11:33:01 EDT
Can this be tested on the same hardware with some other storage controller?  I'm want to be sure we're seeing a problem with the raid controller, as opposed to some problem specific to the machine's firmware.
Comment 10 Peter Jones 2012-04-02 11:36:10 EDT
Actually, nevermind that.  The problem here is that you don't have a splashimage configured in grub.conf , which is resulting in EFI's Graphics Output Protocol never being detected, and in turn results in no console device once linux is loaded.

This grub.conf is inconsistent with how anaconda writes out config files - how is this grub.conf being generated?
Comment 11 Adam Williamson 2012-04-02 11:38:00 EDT
I haven't actually tested a Beta EFI install yet myself, peter, so we may have a bug there.

If the bootloader was just written out by anaconda, can we get program.log?

I'll try an EFI install too.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Tim Flink 2012-04-02 13:01:37 EDT
Created attachment 574557 [details]
grub.conf generated by anaconda during F17 beta RC2 EFI install

As another point of reference, I did an install of F17 beta RC2 to an EFI box with a single SATA disk and no RAID controller used (one is present in the machine but was not used for the install)

Attaching the generated grub.conf and program.log from anaconda to this bug.
Comment 13 Tim Flink 2012-04-02 13:02:21 EDT
Created attachment 574558 [details]
anaconda program.log from F17 beta RC2 EFI install
Comment 14 Tim Flink 2012-04-02 13:35:32 EDT
Created attachment 574572 [details]
anaconda log from F17 beta RC2 EFI install
Comment 15 Tim Flink 2012-04-02 13:36:03 EDT
Created attachment 574573 [details]
anaconda storage.log from F17 beta RC2 EFI install
Comment 16 Tim Flink 2012-04-02 13:36:30 EDT
Created attachment 574574 [details]
syslog from F17 beta RC2 EFI install
Comment 17 Tim Flink 2012-04-02 14:08:22 EDT
Created attachment 574582 [details]
yum log from F17 beta RC2 EFI install
Comment 18 Adam Williamson 2012-04-02 15:05:40 EDT
Discussed at 2012-04-02 blocker review meeting. The conclusion we came to during the meeting was that more information was needed to vote on blocker status; things have developed since then. We seem to be working now on the theory this is a problem with the grub config generated during an EFI install. There definitely seems to be a problem here. Other test installs haven't failed to boot, but they have given an ASCII boot menu when they should give a graphical one, which indicates a bug in the config generation, as I understand things.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2012-04-02 16:05:21 EDT
Xiaowei, can you please re-test with updates=http://pjones.fedorapeople.org/updates.img ?

We think we know the problem here: there's a bug in the grub.cfg generation for EFI installs which means it doesn't set up graphical grub.

This sounds trivial, but actually, on systems without graphics cards that can do KMS, it can result in this happening, because nothing sets up a console, so you're just stuck. We need to ensure gfxboot setup works on EFI installs so non-KMS systems get consoles.

The updates.img should fix the grub.cfg generation, so you should get graphical grub and successful boot after that. We think.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Adam Williamson 2012-04-03 19:13:11 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Fedora Update System 2012-04-03 20:26:43 EDT
anaconda-17.17-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.17-1.fc17
Comment 22 Adam Williamson 2012-04-03 21:32:23 EDT
Discussed at 2012-04-03 emergency blocker review meeting - http://meetbot.fedoraproject.org/fedora-meeting/2012-04-03/fedora-meeting.2012-04-03-23.08.html . We agreed that as we currently understand this bug, the subset of hardware it hits (EFI installs on non-KVM hardware) is so small it's not a blocker, but it is accepted as NTH and the fix will be in RC3.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Xiaowei Li 2012-04-04 22:12:22 EDT
will verify this with the RC3 build.
Comment 24 Fedora Update System 2012-04-05 14:27:45 EDT
Package anaconda-17.17-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.17-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5388/anaconda-17.17-1.fc17
then log in and leave karma (feedback).
Comment 25 Adam Williamson 2012-04-05 23:59:42 EDT
xiaowei: please let us know how it goes, thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Xiaowei Li 2012-04-06 03:04:24 EDT
passed with the RC3 build. attaching the anaconda log files.
Comment 27 Xiaowei Li 2012-04-06 03:06:07 EDT
Created attachment 575630 [details]
anaconda.tar (passed with F17RC3)
Comment 28 Fedora Update System 2012-04-06 09:58:58 EDT
anaconda-17.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.19-1.fc17
Comment 29 Fedora Update System 2012-04-06 19:23:00 EDT
Package anaconda-17.19-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.19-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5447/anaconda-17.19-1.fc17
then log in and leave karma (feedback).
Comment 30 Fedora Update System 2012-04-10 00:14:56 EDT
anaconda-17.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.20-1.fc17
Comment 31 Fedora Update System 2012-04-11 13:22:48 EDT
anaconda-17.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.