Bug 807525 - Add python3-requests subpackage to Fedora 16
Add python3-requests subpackage to Fedora 16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-requests (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Arun S A G
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 23:47 EDT by Eike Hein
Modified: 2012-04-18 18:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-requests-0.11.1-2.fc17
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:42:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add a python3-requests subpackage to python-requests (1.86 KB, application/octet-stream)
2012-03-27 23:49 EDT, Eike Hein
no flags Details

  None (edit)
Description Eike Hein 2012-03-27 23:47:24 EDT
Upstream supports python-requests under all of the Python interpreters distributed in Fedora 16, yet there is no Python 3 version packaged as yet:

    cPython 2.6
    cPython 2.7
    cPython 3.1
    cPython 3.2
    PyPy-c 1.4
    PyPy-c 1.5
    PyPy-c 1.6
    PyPy-c 1.7

(from http://docs.python-requests.org/en/v0.10.7/community/faq/#python-3-support)

I'd like to see a python3-requests sub-package added to Fedora 16 and later.

Do note that requests.async, a sub-functionality of requests, requires python-gevent, which is not available for Python 3 yet. But the core functionality of requests is not impacted by this.

Rex Dieter has written a patch against python-requests.spec to add the sub package that I've tested locally and appears to work. I'll leave attaching it to him.
Comment 1 Eike Hein 2012-03-27 23:49:42 EDT
Created attachment 573217 [details]
Add a python3-requests subpackage to python-requests

Since Rex has gone to bed already I'm taking back my last comment and attaching his patch after all.
Comment 2 Arun S A G 2012-03-28 01:53:14 EDT
(In reply to comment #0)

> Rex Dieter has written a patch against python-requests.spec to add the sub
> package that I've tested locally and appears to work. I'll leave attaching it
> to him.

Thank you. I will update it as soon as possible!
Comment 3 Rex Dieter 2012-03-28 06:40:40 EDT
Hi, I can offer to help update the package too if you don't have time today.
Comment 4 Fedora Update System 2012-03-28 17:19:47 EDT
python-requests-0.10.6-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-requests-0.10.6-3.fc17
Comment 5 Arun S A G 2012-03-28 17:39:29 EDT
(In reply to comment #0)

> 
> I'd like to see a python3-requests sub-package added to Fedora 16 and later.
> 


Do you want python3-requests on Fedora 16 too?
Comment 6 Rex Dieter 2012-03-28 18:21:11 EDT
Yes please, per subject of this report "Add python3-requests subpackage to Fedora 16"  :)
Comment 7 Arun S A G 2012-03-29 03:57:26 EDT
(In reply to comment #6)
> Yes please, per subject of this report "Add python3-requests subpackage to
> Fedora 16"  :)

Oh ok :-). But the version of requests i packaged for Fedora 16 is 0.6.6. It does not support PYTHON 3. I can push 0.10 for Fedora 16, but i will end up violating the update policy https://fedoraproject.org/wiki/Updates_Policy. Any thoughts?
Comment 8 Rex Dieter 2012-03-29 06:46:54 EDT
It's ultimately your call, 
* if the new version risks changing or breaking existing setups 
* if it's primarily for bugfixes
* what your users want and/or expect

if you're still uncomfortable rebasing to 0.10 on f16, I can help prepare a patch against 0.6.x too.
Comment 9 Arun S A G 2012-03-29 07:00:53 EDT
(In reply to comment #8)
> 
> if you're still uncomfortable rebasing to 0.10 on f16, I can help prepare a
> patch against 0.6.x too.

 Is it just the matter of patching the SPEC file or patching the code? I can patch the SPEC file. In case if it is code, i would definitely appreciate your help.
Comment 10 Eike Hein 2012-03-29 10:28:57 EDT
Just to add, I'd definitely love to see a 0.10 version for Python 3 on F16. I have a production app requiring it and am trying to cut down on unpackaged dependencies.

Maybe a workable compromise would be to keep Python 2 on 0.6 for F16, but package 0.10 for Python 3? Since it's a new package it can't violate the update policy.
Comment 11 Rex Dieter 2012-03-29 11:09:19 EDT
While packaging python3-requests separately is an option, that way would be a bit more work too.

So, I'd advocate moving forward with merging the f17+ changes back to f16 and shipping 0.10 there too if at all possible.  That assumes there are no known gotchas for end users doing a 0.6 -> 0.10 updgrade

Now, things are a bit more ok imo, since,
repoquery --whatrequires python-requests
is currently empty (for f16), so there's no risk of breaking other items shipped with fedora at least.
Comment 12 Eike Hein 2012-03-29 11:45:16 EDT
The 0.6 to 0.10 history does include some backwards-incompatible API changes, in particular request.content has become bytes-only and there is a new request.text with the Unicode-decoded response content. This does not necessarily break an app written against the old API, but it could.

However, I would argue to upgrade to 0.10 anyway:

* python-requests is still a young library. The first release was only a little over one year ago, and 0.6 to 0.10 took only four months. Realistically, people using python-requests are essentially early adopters who will be comfortable with how fast it is moving, and are likely to want a recent version.

* Now, early adopters are also more likely to use Python 3, making packaging the lib for Python 3 quite logical - and Python 3 support was added only in 0.10.1.

* Proper SSL certificate support was only added to python-requests in 0.8.8. I would argue that this speaks to the fact that 0.6 is essentially not production-ready and people are unlikely to be depending on its API and would prefer a newer version instead.
Comment 13 Fedora Update System 2012-03-29 23:01:52 EDT
Package python-requests-0.10.6-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-requests-0.10.6-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4894/python-requests-0.10.6-3.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-04-01 02:56:56 EDT
python-requests-0.10.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-requests-0.10.8-1.fc16
Comment 15 Fedora Update System 2012-04-01 03:13:35 EDT
python-requests-0.11.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-requests-0.11.1-1.fc17
Comment 16 Eike Hein 2012-04-01 15:19:55 EDT
Thanks!
Comment 17 Fedora Update System 2012-04-08 14:13:47 EDT
python-requests-0.10.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-requests-0.10.8-2.fc16
Comment 18 Fedora Update System 2012-04-08 14:53:22 EDT
python-requests-0.11.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-requests-0.11.1-2.fc17
Comment 19 Fedora Update System 2012-04-18 15:42:46 EDT
python-requests-0.10.8-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-04-18 18:58:01 EDT
python-requests-0.11.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.