Bug 807538 - Incorrect default NIC for qemu_system_arm: arm can't use rtl8139
Incorrect default NIC for qemu_system_arm: arm can't use rtl8139
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-03-28 01:33 EDT by Stefan Becker
Modified: 2013-08-18 14:59 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 14:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2012-03-28 01:33:54 EDT
Description of problem:

For ARM VMs virt-manager uses the same default NIC ("Hypervisor default"), i.e. PCI device rtl8139, as for x86 VMs. But that driver is not included in the standard Fedora ARM kernels.

When you execute the ARM VM by hand with "qemu-system-arm -net nic ..." then you can see that the default NIC for ARM is

    name "smc91c111", bus System

for which the driver is included in the Fedora ARM kernel.

My knowledge of libvirt XML is limited, but I couldn't write the VM XML in such a way that I could define NIC type "smc91c111" on the bus "System", i.e. that libvirt would execute qemu-system-arm with the correct parameters. So the root cause for this problem might be libvirt, not virt-manager.


Version-Release number of selected component (if applicable):
qemu-system-arm-1.0-9.fc17.x86_64
libvirt-0.9.10-2.fc17.x86_64
virt-manager-0.9.1-2.fc17.noarch
Comment 1 Cole Robinson 2012-04-02 17:02:49 EDT
There are issues with non x86 archs in libvirt and virt-manager. The main blockers are in libvirt though: in an attempt to have stable device addressing it gets the defaults wrong for most non-x86 archs. Reassigning there.
Comment 2 Cole Robinson 2013-08-18 14:59:40 EDT
I posted a series upstream which fixes this issue:

http://www.redhat.com/archives/libvir-list/2013-August/msg00790.html

Just closing as UPSTREAM since I'll probably forget to update this bug when the patches actually land.

Note You need to log in before you can comment on or make changes to this bug.