Bug 807541 - qemu-kvm core dumped when sending cont in monitor to a guest has been paused for 2 hours
qemu-kvm core dumped when sending cont in monitor to a guest has been paused ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.3
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-03-28 01:57 EDT by Chao Yang
Modified: 2013-06-02 03:28 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 03:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2012-03-28 01:57:31 EDT
Description of problem:
Boot a guest with usb-storage attached in cli, during copying big file from usb-storage to system disk, send stop in monitor to guest, send cont in monitor to guest after about 2 hours, core dumped happened at once.

Version-Release number of selected component (if applicable):
# rpm -q qemu-kvm spice-server seabios
qemu-kvm-0.12.1.2-2.253.el6.x86_64
spice-server-0.10.1-4.el6.x86_64
seabios-0.6.1.2-12.el6.x86_64

# uname -r
2.6.32-251.el6.x86_64

How reproducible:
1/1

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
(qemu) c
(qemu) reds_push_tokens: ASSERT reds->agent_state.num_client_tokens <= REDS_AGENT_WINDOW_SIZE failed
Thread 4 (Thread 0x7f23bbfff700 (LWP 25192)):
#0  0x00007f23c9637054 in __lll_lock_wait () from /lib64/libpthread.so.0
#1  0x00007f23c9632388 in _L_lock_854 () from /lib64/libpthread.so.0
#2  0x00007f23c9632257 in pthread_mutex_lock () from /lib64/libpthread.so.0
#3  0x00007f23c9cf3460 in post_kvm_run (kvm=<value optimized out>, env=0x7f23cb26b7c0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:922
#4  0x00007f23c9cf4a2b in kvm_run (env=0x7f23cb26b7c0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1024
#5  0x00007f23c9cf4e89 in kvm_cpu_exec (env=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1743
#6  0x00007f23c9cf5d6d in kvm_main_loop_cpu (_env=0x7f23cb26b7c0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2004
#7  ap_main_loop (_env=0x7f23cb26b7c0) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2060
#8  0x00007f23c9630851 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f23c79f95ad in clone () from /lib64/libc.so.6
Thread 3 (Thread 0x7f23bb5fe700 (LWP 25193)):
#0  0x00007f23c79f16e7 in ioctl () from /lib64/libc.so.6
#1  0x00007f23c9cf49da in kvm_run (env=0x7f23cb285010) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1015
#2  0x00007f23c9cf4e89 in kvm_cpu_exec (env=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1743
#3  0x00007f23c9cf5d6d in kvm_main_loop_cpu (_env=0x7f23cb285010) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2004
#4  ap_main_loop (_env=0x7f23cb285010) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2060
#5  0x00007f23c9630851 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f23c79f95ad in clone () from /lib64/libc.so.6
Thread 2 (Thread 0x7f23b9bfc700 (LWP 25194)):
#0  0x00007f23c79f9ba3 in epoll_wait () from /lib64/libc.so.6
#1  0x00007f23c8171d07 in ?? () from /usr/lib64/libspice-server.so.1
#2  0x00007f23c9630851 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f23c79f95ad in clone () from /lib64/libc.so.6
Thread 1 (Thread 0x7f23c9c45940 (LWP 25181)):
#0  0x00007f23c963754d in read () from /lib64/libpthread.so.0
#1  0x00007f23c81fc6c0 in ?? () from /usr/lib64/libspice-server.so.1
#2  0x00007f23c81fc815 in ?? () from /usr/lib64/libspice-server.so.1
#3  0x00007f23c8174e98 in ?? () from /usr/lib64/libspice-server.so.1
#4  0x00007f23c8177eb4 in ?? () from /usr/lib64/libspice-server.so.1
#5  0x00007f23c8177eb4 in ?? () from /usr/lib64/libspice-server.so.1
#6  0x00007f23c9cd19b0 in qemu_run_timers (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:1323
#7  main_loop_wait (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4153
#8  0x00007f23c9cf2f3a in kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2244
#9  0x00007f23c9cd441c in main_loop (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4331
#10 main (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6591
/usr/lib64/libspice-server.so.1(+0xbe7d5)[0x7f23c81fc7d5]
/usr/lib64/libspice-server.so.1(+0x36e98)[0x7f23c8174e98]
/usr/lib64/libspice-server.so.1(+0x39eb4)[0x7f23c8177eb4]
Aborted (core dumped)


Installed spice-server-debuginfo, switch to thread 2 and thread 1.
(gdb) thread 1
[Switching to thread 1 (Thread 0x7f23c9c45940 (LWP 25181))]#0  0x00007f23c79448a5 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x00007f23c79448a5 in raise () from /lib64/libc.so.6
#1  0x00007f23c7946085 in abort () from /lib64/libc.so.6
#2  0x00007f23c8174e9d in reds_push_tokens () at reds.c:732
#3  add_token () at reds.c:976
#4  0x00007f23c8177eb4 in write_to_vdi_port () at reds.c:782
#5  0x00007f23c8177eb4 in write_to_vdi_port () at reds.c:782
#6  0x00007f23c9cd19b0 in qemu_run_timers (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:1323
#7  main_loop_wait (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4153
#8  0x00007f23c9cf2f3a in kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2244
#9  0x00007f23c9cd441c in main_loop (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4331
#10 main (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6591
(gdb) thread 2
[Switching to thread 2 (Thread 0x7f23b9bfc700 (LWP 25194))]#0  0x00007f23c79f9ba3 in epoll_wait () from /lib64/libc.so.6
(gdb) bt
#0  0x00007f23c79f9ba3 in epoll_wait () from /lib64/libc.so.6
#1  0x00007f23c8171d07 in red_worker_main (arg=<value optimized out>) at red_worker.c:11164
#2  0x00007f23c9630851 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f23c79f95ad in clone () from /lib64/libc.so.6


CLI:
# /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=1,cores=2,threads=1 -name usb-device -uuid 0a94ee47-f42a-4f3f-a8b3-6939740989c1 -boot menu=on -monitor stdio -rtc base=utc,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0 -device piix3-usb-uhci,id=usb,bus=pci.0 -device virtio-scsi-pci,id=scsi-pci -drive file=/dev/chayang-ag/usb-device_virtio-scsi,if=none,id=drive-virtio-disk0,format=qcow2,serial=69-a2ad-85f195fee049,cache=none,werror=stop,rerror=stop,aio=native -device scsi-disk,bus=scsi-pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=0,lun=0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=44:37:E6:5D:42:68,bus=pci.0 -chardev socket,id=charchannel0,path=/opt/usbdevice.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -spice port=9000,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon -device usb-ehci,id=ehci -drive file=/dev/chayang-ag/usb-storage,if=none,id=drive-virtio-disk1,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native,serial=e4977805-a8f6-4854-98a0-edbd1ee9ed58 -device usb-storage,bus=ehci.0,drive=drive-virtio-disk1,id=virtio-disk1,port=1,removable=on
Comment 4 RHEL Product and Program Management 2012-07-10 03:03:57 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 22:01:38 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Uri Lublin 2012-10-14 08:10:55 EDT
Tried to reproduce but works-for-me, with
Host:
   spice-server-0.12.0-1.el6.x86_64
   qemu-kvm-0.12.1.2-2.295.el6_3.2.x86_64

Guest: Windows XP (32 bit).

Chayang, can you reproduce with latest packages ?  Thanks.
Comment 7 David Blechter 2012-10-15 13:41:50 EDT
keep open even devel can't reproduce it. Moving to 6.5 and will address based on the "needinfo" reply
Comment 8 Chao Yang 2012-10-16 04:26:41 EDT
(In reply to comment #6)
> Tried to reproduce but works-for-me, with
> Host:
>    spice-server-0.12.0-1.el6.x86_64
>    qemu-kvm-0.12.1.2-2.295.el6_3.2.x86_64
> 
> Guest: Windows XP (32 bit).
> 
> Chayang, can you reproduce with latest packages ?  Thanks.
Retested with qemu-kvm-0.12.1.2-2.322.el6.x86_64, spice-server-0.12.0-1.el6.x86_64, 2.6.32-332.el6.x86_64 x86_64. Still reproducible while sending stop to qemu monitor with a copy instance alive in guest. Core dump happened after about 20 minutes this time.


What's more:
-----------
# /usr/libexec/qemu-kvm -M rhel6.4.0 -cpu host -enable-kvm -m 2048 -smp 2,sockets=1,cores=2,threads=1 -name usb-device -uuid 0a94ee47-f42a-4f3f-a8b3-6939740989c1 -boot menu=on -monitor stdio -rtc base=utc,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0 -device piix3-usb-uhci,id=usb,bus=pci.0 -device virtio-scsi-pci,id=scsi-pci -drive file=/opt/crash-on-stop-cont.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=69-a2ad-85f195fee049,cache=none,werror=stop,rerror=stop,aio=native -device scsi-disk,bus=scsi-pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=0,lun=0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=44:37:E6:5D:42:68,bus=pci.0 -chardev socket,id=charchannel0,path=/opt/usbdevice.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -spice port=5000,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon -device usb-ehci,id=ehci -drive file=attach-disk.qcow2,if=none,id=drive-virtio-disk1,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native,serial=e4977805-a8f6-4854-98a0-edbd1ee9ed58 -device usb-storage,bus=ehci.0,drive=drive-virtio-disk1,id=virtio-disk1,port=1,removable=on
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) (/usr/libexec/qemu-kvm:7642): Spice-Warning **: reds.c:2830:reds_handle_read_link_done: Peer doesn't support AUTH selection
main_channel_link: add main channel client
main_channel_handle_parsed: net test: latency 0.931000 ms, bitrate 88981578 bps (84.859446 Mbps)
(/usr/libexec/qemu-kvm:7642): Spice-Warning **: reds.c:2830:reds_handle_read_link_done: Peer doesn't support AUTH selection
(/usr/libexec/qemu-kvm:7642): Spice-Warning **: reds.c:2830:reds_handle_read_link_done: Peer doesn't support AUTH selection
red_dispatcher_set_cursor_peer: 
(/usr/libexec/qemu-kvm:7642): Spice-Warning **: reds.c:2830:reds_handle_read_link_done: Peer doesn't support AUTH selection
inputs_connect: inputs channel client create
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  Bug 864345
main_channel_handle_parsed: agent start
main_channel_handle_parsed: agent start
...
(qemu) stop
(qemu) info status 
VM status: paused
(qemu) __spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Need a new bug entry to track this one?

.....
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available
__spice_char_device_write_buffer_get: internal buf is not available

(qemu) 
(qemu) 
(qemu) 
(qemu) __spice_char_device_write_buffer_get: token violation: dev 0x7fe12c052010 client 0x7fe142231f80
spice_char_device_handle_client_overflow: dev 0x7fe12c052010 client 0x7fe1420c5750 
red_client_destroy: destroy client with #channels 4
red_dispatcher_disconnect_display_peer: 
red_channel_client_disconnect: 0x7fe13804d010 (channel 0x7fe12821d0b0 type 2 id 0)
red_channel_client_disconnect: 0x7fe13804d010 (channel 0x7fe12821d0b0 type 2 id 0)
red_channel_client_disconnect: 0x7fe142c5fed0 (channel 0x7fe142154ee0 type 3 id 0)
red_channel_client_disconnect: 0x7fe142c5fed0 (channel 0x7fe142154ee0 type 3 id 0)
red_dispatcher_disconnect_cursor_peer: 
red_channel_client_disconnect: 0x7fe128246780 (channel 0x7fe12821d670 type 4 id 0)
red_channel_client_disconnect: 0x7fe128246780 (channel 0x7fe12821d670 type 4 id 0)
red_channel_client_disconnect: 0x7fe142c4ab70 (channel 0x7fe14214add0 type 1 id 0)
main_channel_client_on_disconnect: rcc=0x7fe142c4ab70
red_channel_client_disconnect: 0x7fe142c4ab70 (channel 0x7fe14214add0 type 1 id 0)
Segmentation fault (core dumped)
Comment 11 Uri Lublin 2012-10-18 08:16:25 EDT
> (In reply to comment #8)

Thanks for re-testing.

I'm not sure it's the same problem.

Do you use spicec (spice-client) as a client or remote-viewer (virt-viewer) ?
If spicec, please give remote-viewer a try (remote-viewer spice://host:port).
Comment 12 langfang 2012-10-19 04:47:51 EDT
hi Uri

  seem hit the same problem on win2008r2 guest

version:
host:
# uname -r
2.6.32-327.el6.x86_64
# rpm -q  qemu-kvm
qemu-kvm-0.12.1.2-2.327.el6.x86_64

# rpm -qa |grep spice-server
spice-server-0.12.0-1.el6.x86_64
spice-server-debuginfo-0.12.0-1.el6.x86_64

guest:win2008r2


1.boot win2008r2 guest
2.(qemu) stop

3.remote-viewer  spice://10.66.106.3:5940
resuts:
[Switching to Thread 0x7fffe5bfc700 (LWP 19853)]
0x00007ffff574c8a5 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install alsa-lib-1.0.22-3.el6.x86_64 celt051-0.5.1.3-0.el6.x86_64 cyrus-sasl-lib-2.1.23-13.el6.x86_64 cyrus-sasl-md5-2.1.23-13.el6.x86_64 cyrus-sasl-plain-2.1.23-13.el6.x86_64 db4-4.7.25-17.el6.x86_64 dbus-libs-1.2.24-5.el6_1.x86_64 flac-1.2.1-6.1.el6.x86_64 glib2-2.22.5-7.el6.x86_64 glibc-2.12-1.80.el6.x86_64 gnutls-2.8.5-4.el6_2.2.x86_64 keyutils-libs-1.4-4.el6.x86_64 krb5-libs-1.9-33.el6.x86_64 libICE-1.0.6-1.el6.x86_64 libSM-1.1.0-7.1.el6.x86_64 libX11-1.3-2.el6.x86_64 libXau-1.0.5-1.el6.x86_64 libXext-1.1-3.el6.x86_64 libXi-1.3-3.el6.x86_64 libXtst-1.0.99.2-3.el6.x86_64 libaio-0.3.107-10.el6.x86_64 libasyncns-0.8-1.1.el6.x86_64 libcom_err-1.41.12-12.el6.x86_64 libgcrypt-1.4.5-9.el6_2.2.x86_64 libgpg-error-1.7-4.el6.x86_64 libjpeg-6b-46.el6.x86_64 libogg-1.1.4-2.1.el6.x86_64 libselinux-2.0.94-5.3.el6.x86_64 libsndfile-1.0.20-5.el6.x86_64 libtasn1-2.3-3.el6_2.1.x86_64 libuuid-2.17.2-12.7.el6.x86_64 libvorbis-1.2.3-4.el6_2.1.x86_64 libxcb-1.5-1.el6.x86_64 nss-softokn-freebl-3.12.9-11.el6.x86_64 openssl-1.0.0-20.el6_2.5.x86_64 pixman-0.18.4-1.el6_0.1.x86_64 pulseaudio-libs-0.9.21-13.el6.x86_64 tcp_wrappers-libs-7.6-57.el6.x86_64 usbredir-0.5.1-1.el6.x86_64 zlib-1.2.3-27.el6.x86_64
(gdb) bt
#0  0x00007ffff574c8a5 in raise () from /lib64/libc.so.6
#1  0x00007ffff574e085 in abort () from /lib64/libc.so.6
#2  0x00007ffff5745a1e in __assert_fail_base () from /lib64/libc.so.6
#3  0x00007ffff5745ae0 in __assert_fail () from /lib64/libc.so.6
#4  0x00007ffff7f73d3d in qxl_send_events (d=0x7ffff9ceb840, events=16) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:1658
#5  0x00007ffff5f837a2 in handle_new_display_channel (opaque=0x7ffec00008c0, payload=0x7ffec01d80a0) at red_worker.c:10370
#6  handle_dev_display_connect (opaque=0x7ffec00008c0, payload=0x7ffec01d80a0) at red_worker.c:11216
#7  0x00007ffff5f63cc7 in dispatcher_handle_single_read (dispatcher=0x7ffff88f98e8) at dispatcher.c:139
#8  dispatcher_handle_recv_read (dispatcher=0x7ffff88f98e8) at dispatcher.c:162
#9  0x00007ffff5f8488e in red_worker_main (arg=<value optimized out>) at red_worker.c:11782
#10 0x00007ffff7740851 in start_thread () from /lib64/libpthread.so.0
#11 0x00007ffff580167d in clone () from /lib64/libc.so.6
Comment 13 langfang 2012-10-19 04:55:06 EDT
can be easily reproduce, wait about 3min when after do "stop" on qemu.
Comment 16 Yonit Halperin 2013-05-28 11:10:37 EDT
I couldn't reproduce any of the crashes described in the comments, with spice-server-0.12.0-12.el6_4.1.
chayang, do you manage to reproduce with latest spice-server?
Comment 17 Chao Yang 2013-05-30 22:33:19 EDT
(In reply to Yonit Halperin from comment #16)
> I couldn't reproduce any of the crashes described in the comments, with
> spice-server-0.12.0-12.el6_4.1.
> chayang, do you manage to reproduce with latest spice-server?

I tried, this issue is no longer reproducible to me. I kept it being stopped for whole night, no core dump happened. But "__spice_char_device_write_buffer_get: internal buf is not available" is still observed. It flooded qemu-kvm monitor while keeping cursor focusing and moving on remote-viewer.

Packages tested:
2.6.32-358.6.3.el6.x86_64
qemu-kvm-0.12.1.2-2.355.el6_4.5.x86_64
spice-server-0.12.0-12.el6_4.1.x86_64
Comment 18 Yonit Halperin 2013-06-02 03:28:39 EDT
(In reply to chayang from comment #17)
> (In reply to Yonit Halperin from comment #16)
> > I couldn't reproduce any of the crashes described in the comments, with
> > spice-server-0.12.0-12.el6_4.1.
> > chayang, do you manage to reproduce with latest spice-server?
> 
> I tried, this issue is no longer reproducible to me. I kept it being stopped
> for whole night, no core dump happened. But
> "__spice_char_device_write_buffer_get: internal buf is not available" is
> still observed. It flooded qemu-kvm monitor while keeping cursor focusing
> and moving on remote-viewer.
> 
> Packages tested:
> 2.6.32-358.6.3.el6.x86_64
> qemu-kvm-0.12.1.2-2.355.el6_4.5.x86_64
> spice-server-0.12.0-12.el6_4.1.x86_64

The above message is not a bug, and has already been silenced in upstream. Once we rebase spice-server (bug #952671) it will no longer appear.
I think the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.