This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 807544 - Kernel: VLAN interface can't change MAC addrs when the interface below it changed
Kernel: VLAN interface can't change MAC addrs when the interface below it cha...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
All All
high Severity high
: beta
: 6.4
Assigned To: Weiping Pan
Network QE
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2012-03-28 02:07 EDT by Liang Zheng
Modified: 2015-01-04 16:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 03:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Zheng 2012-03-28 02:07:47 EDT
Description of problem:
When QE testing bz800231, add a vlan on top of the bond, set fail_over_mac=active,change the active slave, the bond0 and the slaves are all changed the MAC addr except the VLAN interface.

Version-Release number of selected component (if applicable):
kernel-2.6.32.257.el6

How reproducible:
100%

Steps to Reproduce:
1.vconfig add eth0 3
2.ifconfig eth0.3 up
3.ifconfig eth0 hw ether 22:22:22:22:22:22
4.check the MAC addr of eth0.3
ifconfig eth0.3
  
Actual results:
the vlan interface doesnot change the MAC addr.

Expected results:


Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=800231
Comment 1 Weiping Pan 2012-04-11 03:01:32 EDT
Hi, Liang Zheng,

IMHO, this is not a bug. 
I think eth0.3 has a loose relationship with eth0, they can have different settings.
It is not like bonding, that bonding device has a close relationship with its slaves.

P.S.
The behaviour is the same in upstream.

thanks
Weiping Pan
Comment 3 Rashid Khan 2012-04-30 17:06:41 EDT
Hi, Liang Zheng,
Can you please reply to Weiping's comments below. I tend to agree with him on his assessment. Please let us know if you think otherwise. 
Thanks
Comment 4 Liang Zheng 2012-05-01 23:27:29 EDT
(In reply to comment #3)
> Hi, Liang Zheng,
> Can you please reply to Weiping's comments below. I tend to agree with him on
> his assessment. Please let us know if you think otherwise. 
> Thanks
I have discussed with Weiping before,but I donet agree him.
There is some discussion on upstream, you can refer it :
http://patchwork.ozlabs.org/patch/153551/
Comment 6 Weiping Pan 2012-05-03 22:02:02 EDT
The suggested patch has not been accepted in upstream.
I will pay attention to the discussion and then decide whether it is a bug and how to handle it.
Comment 10 Weiping Pan 2013-09-22 03:29:37 EDT
Hi,

From the comments in [1], the maintainers do not think this is a bug,
so I will close it.

[1] http://patchwork.ozlabs.org/patch/118525/

thanks
Weiping Pan

Note You need to log in before you can comment on or make changes to this bug.