Bug 807560 - haproxy-1.4 should be hidden from user interface.
haproxy-1.4 should be hidden from user interface.
Status: CLOSED DUPLICATE of bug 895269
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 03:11 EDT by Johnny Liu
Modified: 2013-11-17 19:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 17:53:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-03-28 03:11:52 EDT
Description of problem:
As far as I know, haproxy-1.4 is used for scaling functionality.
Now when user get embed cartridge list whatever from CLI or rest api,
haproxy-1.4 is always listed there.
If some user embed this cartridge, his app will can not be available, his app does not become scalable either. 
So I think we should hide "haproxy-1.4" from user interface.

Version-Release number of selected component (if applicable):
devenv_1677

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Xiaoli Tian 2012-03-29 22:43:42 EDT
Also think should be hidden from site as well.
Comment 2 Rob Millner 2012-06-25 15:34:27 EDT
We support converting an existing application to scalable by embedding haproxy.  It has to be offered as an option.
Comment 3 Johnny Liu 2012-07-23 05:28:19 EDT
Re-test this bug on devenv_1976, according to "We support converting an existing application to scalable by embedding haproxy", so I tried it.

1. Create a non-scalable app
2. Embed haproxy to this app.
$ rhc-ctl-app -L

List of supported embedded cartridges:

Obtaining list of cartridges (please excuse the delay)...
mongodb-2.0, cron-1.4, mysql-5.1, postgresql-8.4, haproxy-1.4, 10gen-mms-agent-0.1, phpmyadmin-3.4, metrics-0.1, phpmoadmin-1.0, rockmongo-1.1, jenkins-client-1.4

$ rhc-ctl-app -a phptest -e add-haproxy-1.4 -p xx

RESULT:
Success

$ rhc-domain-info -p xx
Application Info
================
phptest
    Framework: php-5.3
     Creation: 2012-07-23T05:15:12-04:00
         UUID: 4d6cd4a5d87542e1a6b8002b261d4e49
      Git URL: ssh://4d6cd4a5d87542e1a6b8002b261d4e49@phptest-jialiu.dev.rhcloud.com/~/git/phptest.git/
   Public URL: http://phptest-jialiu.dev.rhcloud.com/

 Embedded: 
      haproxy-1.4

3. Access this app's URL, only happroxy-status page is seen.
4. Try to scale-up, still failed.
$ curl -k -X POST -H 'Accept: application/xml' -d event=scale-up --user jialiu@redhat.com:214214 https://ec2-75-101-219-128.compute-1.amazonaws.com/broker/rest/domains/jialiu/applications/phptest/events
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <supported-api-versions>
    <supported-api-version>1.0</supported-api-version>
    <supported-api-version>1.1</supported-api-version>
  </supported-api-versions>
  <data>
    <datum nil="true"></datum>
  </data>
  <messages>
    <message>
      <text>Failed to add event scale-up to application phptest due to: Cannot scale a non-scalable application</text>
      <severity>error</severity>
      <field nil="true"></field>
      <exit-code>255</exit-code>
    </message>
  </messages>
  <version>1.1</version>
  <status>unprocessable_entity</status>
  <type nil="true"></type>
</response>

This app looks like still a non-scalable app, that means an existing app is not converted to scalable by embedding haproxy.

I am not sure if this converting functionality is aleady completed, if not, this bug should not be closed as "NOTABUG".
Comment 4 Rob Millner 2013-01-16 17:53:59 EST

*** This bug has been marked as a duplicate of bug 895269 ***

Note You need to log in before you can comment on or make changes to this bug.