Bug 807571 - mod_dav_svn: SVNListParentPath and AuthzSVNAccessFile conflict [NEEDINFO]
mod_dav_svn: SVNListParentPath and AuthzSVNAccessFile conflict
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subversion (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Joe Orton
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 04:04 EDT by Petr Sklenar
Modified: 2015-03-04 09:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-04 09:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jorton: needinfo? (psklenar)


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-03-28 04:04:54 EDT
Description of problem:
directive AuthzSVNAccessFile doesn't work well together with SVNListParentPath on

Version-Release number of selected component (if applicable):
mod_dav_svn-1.6.11-5.el6
subversion-1.6.11-5.el6

How reproducible:
deterministic

Steps to Reproduce:
0. there are svn repositories in /var/www/svn/

1. cat /etc/httpd/conf.d/subversion.conf
<Location /example/>
  DAV svn
  SVNParentPath /var/www/svn/
  SVNListParentPath on

  AuthBasicProvider file
  AuthType Basic
  AuthName "Subversion"
  AuthUserFile /etc/httpd/conf/subversion.passwd
  Require valid-user

  Order allow,deny
  Allow from All
  Satisfy Any
  Options Indexes MultiViews IncludesNoExec

  AuthzForceUsernameCase Lower
  AuthzSVNAccessFile /etc/httpd/conf/subversion.authorization

</Location>


2. cat /etc/httpd/conf/subversion.authorization
[*]
* = rw
[/]
* = rw
  
Actual results:
you need to specify '<Location /example/>' to be able list parent repositories.
'<Location /example>' doesn't allow you to list collection of repositories.
  

Expected results:
'<Location /example>' is enough and you can see collection of repositories on http://<hostname>/example

Which works well when you comment out AuthzSVNAccessFile line


Additional info:

There is common work around for authz and SVNListParentPath issue
RedirectMatch ^(/example)$ $1/
Comment 2 RHEL Product and Program Management 2012-05-03 01:29:21 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.