Bug 807668 - RFE: After metadata download, Pulp should report when is not enough disc space for rpms or files
RFE: After metadata download, Pulp should report when is not enough disc spac...
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: amacdona@redhat.com
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 08:52 EDT by Lukas Zapletal
Modified: 2014-11-19 16:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-19 16:05:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulp.log (2.76 KB, text/plain)
2012-03-28 09:03 EDT, Og Maciel
no flags Details
/var/log/messages (3.95 KB, text/plain)
2012-03-28 09:04 EDT, Og Maciel
no flags Details

  None (edit)
Description Lukas Zapletal 2012-03-28 08:52:19 EDT
We hit out of disc space errors way too often while working in Katello and I can imagine there will be users hitting the similar issues.

The problem is sync can be quite long and we should maybe report this in advance to the user.

My request is to implement disc size check before starting downloading rpms or iso files (or where possible) and have an option to disable this behavior. By default it should be switched on.
Comment 1 Og Maciel 2012-03-28 09:03:00 EDT
Having just gone through a case where I ran out of disk space, I'm attaching the tracebacks found on pulp.log and messages log in case it may provide useful information.
Comment 2 Og Maciel 2012-03-28 09:03:42 EDT
Created attachment 573348 [details]
pulp.log

Python traceback from pulp.log
Comment 3 Og Maciel 2012-03-28 09:04:14 EDT
Created attachment 573349 [details]
/var/log/messages

/var/log/messages
Comment 4 amacdona@redhat.com 2014-11-19 16:05:12 EST
I do not think it is possible for Pulp to predict running out of disk space, especially since these items are being stored in a database.

When the disk is full, it is Mongo, not Pulp that crashes. Pulp correctly responds that it cannot connect to the database. 

I am closing for now, please feel free to reopen if I missed something.

Note You need to log in before you can comment on or make changes to this bug.