Bug 807673 - RFE: Create a brand with support for "Process" styles
RFE: Create a brand with support for "Process" styles
Status: CLOSED DEFERRED
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joshua Wulf
:
Depends On: 749735 840296
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 09:11 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-29 12:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-28 09:11:21 EDT
None of the currently existing Publican brands has appropriate styling for the links that are injected by the Process keyword. 

The links should be appropriately sized and styled so that they become navigational aids, but do not draw too much attention to themselves. At the moment they cause the page to become too busy.

The purpose is to communicate to the user who randomly lands in the middle of a process (through search or page-flipping) that this task does not exist in isolation, but rather depends on a persistent state that develops over the successive execution of a number of interdependent tasks.
Comment 1 Lee Newson 2012-03-28 19:35:33 EDT
While I'm not very familiar with this. Perhaps the right approach is to submit the addons for the existing brands? There are far too many brands to replicate for just adding process styling.

With the exception of the title which has the link back to the chapter. All have a style role setup. So from my POV that should be the way that this is handled.
Comment 2 Joshua Wulf 2012-03-28 20:48:20 EDT
The css to weight and position the process injected links needs to be prototyped in one brand first, then a patch submitted to the existing brands.

They'll take the patch when they (a) go to CSP-generated output, and (b) want to use Processes. 

(b) depends on making the Processes usable in terms of their display. Right now, with no css support the links are not positioned or weighted in a way that the Process injection enhances usability (my opinion - and you'd think I'd be biased towards Processes).  

I've opened this bug to point this out in the Guide where I describe Processes. I may get to prototyping css styling for it, in which case I'll post the brand / patch here, and readers of the Guide can find it; or someone else might do it, in which case they can post a link to the brand / css patch here, and others can try it out / merge the patch.
Comment 3 Lee Newson 2012-03-28 20:57:34 EDT
k good to know the process :)

I checked and there is a role assigned to the title. So the valid roles are:
process-next-title
process-next-link
process-previous-title
process-previous-link
Comment 4 Joshua Wulf 2012-07-09 08:15:33 EDT
OK, I can do this now.

I'm going to do a css mod for it and test it on the RHEV docs, which use this pattern.

I wonder whether this might not turn out to be better though:

Since in html-single the next and previous steps are indicated by the sequential layout of the page, the links are superfluous, so they might need to be suppressed in html-single output.

In chunked html these links might be overkill. A better approach may be to programatically (in the csp) generated an ephemeral (dynamically-generated) topic which is a numbered list of links to the steps, and inject into each process step a link back to this topic.

That's a lighter pattern that achieves a better balance between navigable and low metadata load.
Comment 5 Joshua Wulf 2012-10-24 00:38:54 EDT
xrefstyles and roles are applied to the links, as per https://bugzilla.redhat.com/show_bug.cgi?id=840296#c2
Comment 6 Joshua Wulf 2012-10-24 00:46:57 EDT
The "overview topic" idea mentioned in comment 4 is discussed here: https://bugzilla.redhat.com/show_bug.cgi?id=840296#c6
> 
> In chunked html these links might be overkill. A better approach may be to
> programatically (in the csp) generated an ephemeral (dynamically-generated)
> topic which is a numbered list of links to the steps, and inject into each
> process step a link back to this topic.
> 
> That's a lighter pattern that achieves a better balance between navigable
> and low metadata load.
Comment 7 Jared MORGAN 2012-10-24 00:48:09 EDT
The EPP 6 Installation Guide is a prime candidate for testing and tweaking how Process blocks  display in html-single. It has significant sequential tasks, and refers back to other tasks earlier in the guide to ensure a reader doesn't hit configuration dead-ends.

I volunteer time to work with jwulf on this, once smumford completes this guide in CCMS to a publishable state.

ETA for a publishable version of this guide is 2nd Nov 2012
Comment 8 Joshua Wulf 2013-04-29 12:23:09 EDT
Deferring.

Note You need to log in before you can comment on or make changes to this bug.