Bug 807679 - user-agent sent by rhnreg_ks do not contain version number, just '$Revision$' string
user-agent sent by rhnreg_ks do not contain version number, just '$Revision$'...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-03-28 09:44 EDT by Jan Hutař
Modified: 2012-11-01 12:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhnlib-2.5.52-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 12:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-03-28 09:44:15 EDT
Description of problem:
Recently I got a traceback mail from spacewalk generated during registration and the traceback mail contain info about request rhnreg_ks did. One of the fields is "Headers passed in: -> user-agent: rhn.rpclib.py/$Revision$" which do not seem correct.


Version-Release number of selected component (if applicable):
rhnlib-2.5.51-1.el5 or rhnlib-2.5.22-12.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. Check which headers rhnreg_ks sends to the server when calling registration.new_system (I have provoked the traceback by attempting to register system when I do not have enough entitlements for that - this seems to be a different error which will be probably reported as different bug)


Actual results:
Exception reported from <fqdn>
Time: Tue Mar 27 20:52:44 2012
Exception type spacewalk.common.rhnException.rhnException
Exception while handling function registration.new_system
Request object information:
URI: /XMLRPC
Remote Host: <fqdn>
Server Name: <fqdn>:443
Headers passed in:
	Accept-Encoding: identity
	Content-Length: 1612
	Host: <fqdn>:443
	content-type: text/xml
	user-agent: rhn.rpclib.py/$Revision$
	x-client-version: 1
	x-info: RPC Processor (C) Red Hat, Inc (version $Revision$)
	x-rhn-client-capability: caneatCheese(1)=1,packages.extended_profile(2)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.update(2)=2,packages.rollBack(1)=1
	x-rhn-transport-capability: follow-redirects=3
	x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc (version $Revision$)
	x-up2date-version: 1.7.14-1.el5
[...]

Specifically check "user-agent", "x-info" and "x-transport-info" which have "$Revision$" in it.


Expected results:
IMO that string should be expanded into some version or number.
Comment 2 Jan Pazdziora 2012-03-29 03:38:44 EDT
Fixed in Spacewalk master, e7c6e67a859d6c7d8bb8fe61473abe30b559bc19.
Comment 3 Jan Pazdziora 2012-10-30 15:25:28 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 4 Jan Pazdziora 2012-11-01 12:21:17 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.